summaryrefslogtreecommitdiff
path: root/meta/packages/gtkhtml2/gtkhtml2_svn.bb
diff options
context:
space:
mode:
authorIan Holmes <iain@openedhand.com>2007-04-05 15:46:45 +0000
committerIan Holmes <iain@openedhand.com>2007-04-05 15:46:45 +0000
commit4390d5c31980324774c3cc6c411b77db14327771 (patch)
tree94f633433e95595a5418e0568ef1c14a4aed5775 /meta/packages/gtkhtml2/gtkhtml2_svn.bb
parent166b9363694c417782ed20acce0c8db44851a410 (diff)
downloadopenembedded-core-4390d5c31980324774c3cc6c411b77db14327771.tar.gz
openembedded-core-4390d5c31980324774c3cc6c411b77db14327771.tar.bz2
openembedded-core-4390d5c31980324774c3cc6c411b77db14327771.tar.xz
openembedded-core-4390d5c31980324774c3cc6c411b77db14327771.zip
Move gtkhtml2 to use gnome svn rather than gnome cvs
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1443 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gtkhtml2/gtkhtml2_svn.bb')
-rw-r--r--meta/packages/gtkhtml2/gtkhtml2_svn.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/gtkhtml2/gtkhtml2_svn.bb b/meta/packages/gtkhtml2/gtkhtml2_svn.bb
new file mode 100644
index 000000000..a2eb95ad6
--- /dev/null
+++ b/meta/packages/gtkhtml2/gtkhtml2_svn.bb
@@ -0,0 +1,28 @@
+SECTION = "libs"
+DEPENDS = "gtk+ glib-2.0 libxml2"
+DESCRIPTION = "A GTK+ HTML rendering library."
+LICENSE = "GPL"
+PV = "2.11.0+svn${SRCDATE}"
+PR = "r3"
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN};module=trunk;proto=http \
+ http://svn.o-hand.com/repos/web/trunk/patches/at-import_box-pos.patch;patch=1;pnum=0 \
+ http://svn.o-hand.com/repos/web/trunk/patches/css-stylesheet-user.patch;patch=1;pnum=0 \
+ http://svn.o-hand.com/repos/web/trunk/patches/css-media.patch;patch=1;pnum=0 \
+ http://svn.o-hand.com/repos/web/trunk/patches/add-end-element-signal.patch;patch=1;pnum=0 \
+ http://svn.o-hand.com/repos/web/trunk/patches/add-dom-functions.patch;patch=1;pnum=0 \
+ http://svn.o-hand.com/repos/web/trunk/patches/iain-mem-leak.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/trunk"
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --disable-accessibility"
+
+do_stage() {
+ oe_libinstall -so -C libgtkhtml libgtkhtml-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
+ ( for i in css document dom dom/core dom/events dom/html dom/traversal dom/views graphics layout layout/html util view; do install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; install -m 0644 ${S}/libgtkhtml/$i/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; done )
+ install -m 0644 ${S}/libgtkhtml/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
+}
+