summaryrefslogtreecommitdiff
path: root/meta/packages/hal/files/hal-right-input-h.patch
diff options
context:
space:
mode:
authorVivian Zhang <vivian.zhang@intel.com>2008-11-12 14:15:50 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-01 20:42:56 +0000
commitfdc825062564e5145fdd1ebe6c7bd416429dfd82 (patch)
tree803d41440ca647ab39867d3ea78e71c5abbea475 /meta/packages/hal/files/hal-right-input-h.patch
parent1eb027228092b73e90bc3281ba050148f641d817 (diff)
downloadopenembedded-core-fdc825062564e5145fdd1ebe6c7bd416429dfd82.tar.gz
openembedded-core-fdc825062564e5145fdd1ebe6c7bd416429dfd82.tar.bz2
openembedded-core-fdc825062564e5145fdd1ebe6c7bd416429dfd82.tar.xz
openembedded-core-fdc825062564e5145fdd1ebe6c7bd416429dfd82.zip
upgrade hal to 0.5.11 and hal-info to 20080508(from OE)
Diffstat (limited to 'meta/packages/hal/files/hal-right-input-h.patch')
-rw-r--r--meta/packages/hal/files/hal-right-input-h.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/hal/files/hal-right-input-h.patch b/meta/packages/hal/files/hal-right-input-h.patch
new file mode 100644
index 000000000..f820b7790
--- /dev/null
+++ b/meta/packages/hal/files/hal-right-input-h.patch
@@ -0,0 +1,29 @@
+diff --git a/configure.in b/configure.in
+index e76ff51..5e8cc21 100644
+--- a/configure.in
++++ b/configure.in
+@@ -983,6 +983,11 @@ AC_ARG_WITH([linux-input-header],
+ [Use an given Linux input.h rather than that installed on the system (<linux/input.h>)]))
+ if test "x$with_linux_input_header" != "x"; then
+ AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>])
++ LINUX_INPUT_H=$with_linux_input_header
++ AC_SUBST(LINUX_INPUT_H)
++else
++ LINUX_INPUT_H=/usr/include/linux/input.h
++ AC_SUBST(LINUX_INPUT_H)
+ fi
+
+ dnl
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index ae03edd..7d1cbab 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -79,7 +79,7 @@ endif
+ if BUILD_KEYMAPS
+
+ if HAVE_GPERF
+-hal-setup-keymap-keys.txt: /usr/include/linux/input.h
++hal-setup-keymap-keys.txt: @LINUX_INPUT_H@
+ awk '/^#define.*KEY_/ { if ($$2 != "KEY_MAX") { print substr($$2, 5) } }' < $< > $@
+
+ hal-setup-keymap-hash-name.gperf: hal-setup-keymap-keys.txt