summaryrefslogtreecommitdiff
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-01 17:01:35 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-02 15:32:44 -0700
commit06ecb32bf32ef9d8ed4e871266e082a57d393dc3 (patch)
tree680b050fab75a2a855abfec6e507295c4773d151 /meta/packages/hal
parent5061f7be7dc25850d07a883bccd2149adf73e090 (diff)
downloadopenembedded-core-06ecb32bf32ef9d8ed4e871266e082a57d393dc3.tar.gz
openembedded-core-06ecb32bf32ef9d8ed4e871266e082a57d393dc3.tar.bz2
openembedded-core-06ecb32bf32ef9d8ed4e871266e082a57d393dc3.tar.xz
openembedded-core-06ecb32bf32ef9d8ed4e871266e082a57d393dc3.zip
hal: fix metadata
add bugtracker, update license The detail license is very complex and not easy to be expressed in a single LICENSE line. Adopt a simple notation here, and will describe details when the package is actually being upgraded. hal_git doesn't use hal.inc, need further cleanups. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/hal.inc14
-rw-r--r--meta/packages/hal/hal_git.bb10
2 files changed, 14 insertions, 10 deletions
diff --git a/meta/packages/hal/hal.inc b/meta/packages/hal/hal.inc
index 4d72e94fa..2b70eb714 100644
--- a/meta/packages/hal/hal.inc
+++ b/meta/packages/hal/hal.inc
@@ -1,22 +1,24 @@
DESCRIPTION = "Hardware Abstraction Layer"
HOMEPAGE = "http://freedesktop.org/Software/hal"
+BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=hal"
SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz"
-
-S = "${WORKDIR}/hal-${PV}"
-
-inherit autotools pkgconfig
+LICENSE = "GPLv2+ | AFL"
DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb gperf-native"
RDEPENDS += "udev hal-info"
RRECOMMENDS = "udev-utils"
+SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz"
SRC_URI += "file://99_hal \
file://20hal \
"
+S = "${WORKDIR}/hal-${PV}"
+
+inherit autotools pkgconfig
+
+
LEAD_SONAME = "libhal.so"
# machines with pci and acpi get a machine dependant hal
diff --git a/meta/packages/hal/hal_git.bb b/meta/packages/hal/hal_git.bb
index 21fde21fe..85bb777d5 100644
--- a/meta/packages/hal/hal_git.bb
+++ b/meta/packages/hal/hal_git.bb
@@ -1,19 +1,21 @@
DESCRIPTION = "Hardware Abstraction Layer"
HOMEPAGE = "http://freedesktop.org/Software/hal"
+BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=hal"
SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
+
+LICENSE = "GPLv2+ | AFL"
DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
RDEPENDS_${PN} += "udev hal-info"
RRECOMMENDS_${PN} += "udev-utils"
+PV = "0.5.9.1+git${SRCDATE}"
+PR = "r4"
+
SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
file://20hal \
file://99_hal"
-PV = "0.5.9.1+git${SRCDATE}"
-PR = "r4"
-
S = "${WORKDIR}/git"
inherit autotools pkgconfig