summaryrefslogtreecommitdiff
path: root/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.bz2
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.xz
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.zip
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb')
-rw-r--r--meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb b/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
new file mode 100644
index 000000000..12ed042f1
--- /dev/null
+++ b/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Itsy Package Manager utilities"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+CONFLICTS = "ipkg-link"
+RDEPENDS = "python"
+SRCDATE = "20050404"
+PR = "r11"
+
+SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
+
+S = "${WORKDIR}/ipkg-utils"
+
+INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py"
+
+do_compile() {
+ oe_runmake ipkg-compare-versions
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for i in ${INSTALL}
+ do
+ install -m 0755 $i ${D}${bindir}
+ done
+}
+
+#FIXME: ipkg-utils is not allowed to have packages or else a ipkg-native -> ipkg-utils -> ipkg-utils
+# recursive dependency is triggered. This has been fixed by installing the ipkg-link script in
+# a dedicated package.
+#PACKAGES_prepend = "ipkg-link "
+#FILES_ipkg-link = "${bindir}/ipkg-link"
+