summaryrefslogtreecommitdiff
path: root/meta/packages/iproute2/iproute2.inc
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-06-25 17:48:52 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-29 17:13:38 +0100
commitb180d7f488f44d3dfb3f9a19604e9592c29b426e (patch)
treedc198fec816ec648c27298f9c7869b592727a221 /meta/packages/iproute2/iproute2.inc
parent7510eb1061d0795b515bd20eba1cbd39a9b644a2 (diff)
downloadopenembedded-core-b180d7f488f44d3dfb3f9a19604e9592c29b426e.tar.gz
openembedded-core-b180d7f488f44d3dfb3f9a19604e9592c29b426e.tar.bz2
openembedded-core-b180d7f488f44d3dfb3f9a19604e9592c29b426e.tar.xz
openembedded-core-b180d7f488f44d3dfb3f9a19604e9592c29b426e.zip
iproute: upgrade to 2.6.34
(borrow from OE 2.6.34 recipe) [Patches-poky] REMOVE _iproute2-2.6.15_no_strip.diff_: not required now REMOVE _new-flex-fix.patch_: not required now [Patches-OE] TAKE _configure-cross.patch_: don't invoke gcc directly [Recipes] - Add metadata - fix SRC_URI for new version - no {S} now - use alternative to enable 'ip' instead of using busybox - move shared documents to right destination - not take from OE: * no need for specific do_configure Signed-off-by Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/iproute2/iproute2.inc')
-rw-r--r--meta/packages/iproute2/iproute2.inc21
1 files changed, 15 insertions, 6 deletions
diff --git a/meta/packages/iproute2/iproute2.inc b/meta/packages/iproute2/iproute2.inc
index 0d7b11028..7246b87e9 100644
--- a/meta/packages/iproute2/iproute2.inc
+++ b/meta/packages/iproute2/iproute2.inc
@@ -1,18 +1,27 @@
DESCRIPTION = "kernel routing and traffic control utilities"
+HOMEPAGE = "http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
SECTION = "base"
-LICENSE = "GPL"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://ip/ip.c;md5=186731afa4b42e30b9b37efa4ec90b93"
DEPENDS = "flex-native bison-native"
-# Set SRCDATE in the .bb file
-SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${SRCDATE}.tar.gz"
-
-S = "${WORKDIR}/${P}-${SRCDATE}"
+inherit update-alternatives
EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin"
do_install () {
- oe_runmake DESTDIR=${D} install
+ oe_runmake DESTDIR=${D} install
+ mv ${D}${base_sbindir}/ip ${D}${base_sbindir}/ip.iproute2
+ install -d ${D}${datadir}
+ mv ${D}/share/* ${D}${datadir}/ || true
+ rm ${D}/share -rf || true
}
FILES_${PN} += "/usr/lib/tc/*"
FILES_${PN}-dbg += "/usr/lib/tc/.debug"
+
+ALTERNATIVE_NAME = "ip"
+ALTERNATIVE_PATH = "${base_sbindir}/ip.iproute2"
+ALTERNATIVE_LINK = "${base_bindir}/ip"
+ALTERNATIVE_PRIORITY = "100"