summaryrefslogtreecommitdiff
path: root/meta/packages/js/files/link_with_gcc.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-06-18 17:28:11 +0000
committerRichard Purdie <richard@openedhand.com>2007-06-18 17:28:11 +0000
commitb6dc9fc15ac87911aac1dd8fa0ff7ee2c54399d7 (patch)
tree7a7e0ba2014ac17ac76992ebc285ee24fc351768 /meta/packages/js/files/link_with_gcc.patch
parent9dbe065a251e02e4cc3051e55769381eb608657a (diff)
downloadopenembedded-core-b6dc9fc15ac87911aac1dd8fa0ff7ee2c54399d7.tar.gz
openembedded-core-b6dc9fc15ac87911aac1dd8fa0ff7ee2c54399d7.tar.bz2
openembedded-core-b6dc9fc15ac87911aac1dd8fa0ff7ee2c54399d7.tar.xz
openembedded-core-b6dc9fc15ac87911aac1dd8fa0ff7ee2c54399d7.zip
js: Use gcc for linking so LDFLAGS can be used in full rather that hardcoded subsets
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1968 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/js/files/link_with_gcc.patch')
-rw-r--r--meta/packages/js/files/link_with_gcc.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/packages/js/files/link_with_gcc.patch b/meta/packages/js/files/link_with_gcc.patch
new file mode 100644
index 000000000..d74b94f37
--- /dev/null
+++ b/meta/packages/js/files/link_with_gcc.patch
@@ -0,0 +1,13 @@
+Index: src/config/Linux_All.mk
+===================================================================
+--- src.orig/config/Linux_All.mk 2005-05-10 19:53:44.000000000 +0000
++++ src/config/Linux_All.mk 2007-06-18 17:20:05.000000000 +0000
+@@ -47,7 +47,7 @@
+ OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R
+
+ RANLIB = echo
+-MKSHLIB = $(LD) -shared $(XMKSHLIBOPTS)
++MKSHLIB = $(CC) -shared $(XMKSHLIBOPTS)
+
+ #.c.o:
+ # $(CC) -c -MD $*.d $(CFLAGS) $<