summaryrefslogtreecommitdiff
path: root/meta/packages/js/files
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-06-10 22:12:55 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-10 22:12:55 +0100
commit57c7dda03e5067e60177d06d08fdd4322225148c (patch)
treeca85eb63c37e9317c948bf116c12285c4323cc12 /meta/packages/js/files
parentea45876d7ba3d4d2b132fd38a2c40834a2385f34 (diff)
downloadopenembedded-core-57c7dda03e5067e60177d06d08fdd4322225148c.tar.gz
openembedded-core-57c7dda03e5067e60177d06d08fdd4322225148c.tar.bz2
openembedded-core-57c7dda03e5067e60177d06d08fdd4322225148c.tar.xz
openembedded-core-57c7dda03e5067e60177d06d08fdd4322225148c.zip
js: Fix mips build and other architecture inconsistency
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/js/files')
-rw-r--r--meta/packages/js/files/usepic.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/js/files/usepic.patch b/meta/packages/js/files/usepic.patch
new file mode 100644
index 000000000..ddd31be9c
--- /dev/null
+++ b/meta/packages/js/files/usepic.patch
@@ -0,0 +1,24 @@
+Mips needs -fPIC to compile properly. These tests are broken anyway as they test
+the build system architecture, not the target. This is a hack.
+
+RP 10/6/2010
+
+Index: src/config/Linux_All.mk
+===================================================================
+--- src.orig/config/Linux_All.mk 2010-06-10 22:09:43.000000000 +0100
++++ src/config/Linux_All.mk 2010-06-10 22:09:55.000000000 +0100
+@@ -90,14 +90,10 @@
+ # Use the editline library to provide line-editing support.
+ JS_EDITLINE = 1
+
+-ifeq ($(CPU_ARCH),x86_64)
+ # Use VA_COPY() standard macro on x86-64
+ # FIXME: better use it everywhere
+ OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
+-endif
+
+-ifeq ($(CPU_ARCH),x86_64)
+ # We need PIC code for shared libraries
+ # FIXME: better patch rules.mk & fdlibm/Makefile*
+ OS_CFLAGS += -DPIC -fPIC
+-endif