summaryrefslogtreecommitdiff
path: root/meta/packages/libmad/libmad_0.15.1b.bb
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-09-27 15:29:04 +0000
committerChris Lord <chris@openedhand.com>2006-09-27 15:29:04 +0000
commit07be49de5615eb4408dcb2b34b78776515640f6a (patch)
treefab94e05de6a6a51f529be23218ab600d65f71e8 /meta/packages/libmad/libmad_0.15.1b.bb
parent181260df752e4af8605ad055d9810228483975da (diff)
downloadopenembedded-core-07be49de5615eb4408dcb2b34b78776515640f6a.tar.gz
openembedded-core-07be49de5615eb4408dcb2b34b78776515640f6a.tar.bz2
openembedded-core-07be49de5615eb4408dcb2b34b78776515640f6a.tar.xz
openembedded-core-07be49de5615eb4408dcb2b34b78776515640f6a.zip
- Fix mp3 playback (update libmad)
- add mp3 decoder to gst-meta-audio - add avi demuxer to gst-meta-video git-svn-id: https://svn.o-hand.com/repos/poky/trunk@768 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libmad/libmad_0.15.1b.bb')
-rw-r--r--meta/packages/libmad/libmad_0.15.1b.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/packages/libmad/libmad_0.15.1b.bb b/meta/packages/libmad/libmad_0.15.1b.bb
new file mode 100644
index 000000000..aac373613
--- /dev/null
+++ b/meta/packages/libmad/libmad_0.15.1b.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "MPEG Audio Decoder Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libid3tag"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
+S = "${WORKDIR}/libmad-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "-enable-speed --enable-shared"
+# The ASO's don't take any account of thumb...
+EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
+EXTRA_OECONF_append_arm = " --enable-fpm=arm"
+
+do_configure_prepend () {
+# damn picky automake...
+ touch NEWS AUTHORS ChangeLog
+}
+
+do_stage() {
+ oe_libinstall -so libmad ${STAGING_LIBDIR}
+ install -m 0644 mad.h ${STAGING_INCDIR}
+}