summaryrefslogtreecommitdiff
path: root/meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-09-17 00:05:34 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-09-17 22:25:22 +0100
commit0d7207ca39d1671682f9467a804766b151048573 (patch)
tree88a9b9b8588d8df986f4d6f0f4a232ec41841261 /meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb
parentaf85ce4b4e675feb5796f87137c86d70c2f15b9a (diff)
downloadopenembedded-core-0d7207ca39d1671682f9467a804766b151048573.tar.gz
openembedded-core-0d7207ca39d1671682f9467a804766b151048573.tar.bz2
openembedded-core-0d7207ca39d1671682f9467a804766b151048573.tar.xz
openembedded-core-0d7207ca39d1671682f9467a804766b151048573.zip
sdk.bbclass: Rename to nativesdk.bbclass
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb')
-rw-r--r--meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb b/meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb
new file mode 100644
index 000000000..a364ca386
--- /dev/null
+++ b/meta/packages/libsdl/libsdl-nativesdk_1.2.11.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Simple DirectMedia Layer - native Edition"
+HOMEPAGE = "http://www.libsdl.org"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "libx11-nativesdk libxext-nativesdk libxrandr-nativesdk libxrender-nativesdk"
+RDEPENDS = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
+PR = "r4"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+ file://acinclude.m4 \
+ file://configure_tweak.patch;patch=1 \
+ file://kernel-asm-page.patch;patch=1 "
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools_stage binconfig pkgconfig nativesdk
+
+EXTRA_OECONF = "--disable-static --disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
+ --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --disable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-svga \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen"
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ cp ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
+}
+
+do_stage_append() {
+ install -m 0644 ${S}/build/libSDLmain.a ${STAGING_LIBDIR}
+}