summaryrefslogtreecommitdiff
path: root/meta/packages/libusb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-16 12:48:08 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-23 23:53:29 +0100
commit63d56523555b000a4b52027b68d0e7f33bf6a2ec (patch)
treea3857b1b8e402a640ca5fb4ffa6e5d37d61e3f64 /meta/packages/libusb
parent74388f763a9213d826652f647a46b8a6be45496f (diff)
downloadopenembedded-core-63d56523555b000a4b52027b68d0e7f33bf6a2ec.tar.gz
openembedded-core-63d56523555b000a4b52027b68d0e7f33bf6a2ec.tar.bz2
openembedded-core-63d56523555b000a4b52027b68d0e7f33bf6a2ec.tar.xz
openembedded-core-63d56523555b000a4b52027b68d0e7f33bf6a2ec.zip
libusb-compat: upgrade to version 0.1.3
from 0.0.9, also remove libusb recipe (see below) changes: - remove some unnecessary logics derived from libusb-0.1 - now PROVIDES libusb - bluez4 depends on libusb instead of libusb-compat libusb-0.1 vs. libusb-compat libusb-compat is intended to be a drop-in replacement of libusb-0.1, building on top of libusb-1.0 (which has different API from -0.1). Few known packages don't work with libusb-compat, notable example is libmtp. Since most packages work very well with libusb-compat, and libusb-compat doesn't suffer from power consumption issue of libusb-0.1 (which is often very important for embedded systems), drop libusb-0.1 and move to libusb-compat completely. If we see any problems in the future, either the package should be fixed or we can add back libusb-0.1 as needed. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/libusb')
-rw-r--r--meta/packages/libusb/libusb-compat-0.1.3/0.1.0-beta1-gcc3.4-fix.patch (renamed from meta/packages/libusb/libusb-compat-0.0.9+0.1.0-beta2/0.1.0-beta1-gcc3.4-fix.patch)0
-rw-r--r--meta/packages/libusb/libusb-compat_0.0.9+0.1.0-beta2.bb28
-rw-r--r--meta/packages/libusb/libusb-compat_0.1.3.bb23
-rw-r--r--meta/packages/libusb/libusb/configure_fix.patch17
-rw-r--r--meta/packages/libusb/libusb_0.1.12.bb29
5 files changed, 23 insertions, 74 deletions
diff --git a/meta/packages/libusb/libusb-compat-0.0.9+0.1.0-beta2/0.1.0-beta1-gcc3.4-fix.patch b/meta/packages/libusb/libusb-compat-0.1.3/0.1.0-beta1-gcc3.4-fix.patch
index 501ba3fb2..501ba3fb2 100644
--- a/meta/packages/libusb/libusb-compat-0.0.9+0.1.0-beta2/0.1.0-beta1-gcc3.4-fix.patch
+++ b/meta/packages/libusb/libusb-compat-0.1.3/0.1.0-beta1-gcc3.4-fix.patch
diff --git a/meta/packages/libusb/libusb-compat_0.0.9+0.1.0-beta2.bb b/meta/packages/libusb/libusb-compat_0.0.9+0.1.0-beta2.bb
deleted file mode 100644
index 087fe3ada..000000000
--- a/meta/packages/libusb/libusb-compat_0.0.9+0.1.0-beta2.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "libusb is a library to provide userspace \
-access to USB devices."
-HOMEPAGE = "http://www.libusb.org/"
-BUGTRACKER = "http://www.libusb.org/report"
-SECTION = "libs"
-LICENSE = "LGPLv2.1+"
-DEPENDS = "libusb1"
-
-PE = "1"
-PR = "r0"
-
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-0.1.0-beta2.tar.bz2 \
- file://0.1.0-beta1-gcc3.4-fix.patch;patch=1 \
- "
-
-S = "${WORKDIR}/libusb-compat-0.1.0-beta2"
-
-inherit autotools pkgconfig binconfig lib_package
-
-PARALLEL_MAKE = ""
-EXTRA_OECONF = "--disable-build-docs"
-
-export CXXFLAGS += "-lstdc++ -I${STAGING_INCDIR}"
-
-PACKAGES =+ "libusbpp"
-
-FILES_libusbpp = "${libdir}/libusbpp*.so.*"
diff --git a/meta/packages/libusb/libusb-compat_0.1.3.bb b/meta/packages/libusb/libusb-compat_0.1.3.bb
new file mode 100644
index 000000000..e8d6338e5
--- /dev/null
+++ b/meta/packages/libusb/libusb-compat_0.1.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libusb-0.1 compatible layer for libusb1, a drop-in replacement \
+that aims to look, feel and behave exactly like libusb-0.1"
+HOMEPAGE = "http://www.libusb.org/"
+BUGTRACKER = "http://www.libusb.org/report"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423"
+DEPENDS = "libusb1"
+
+# Few packages are known not to work with libusb-compat (e.g. libmtp-1.0.0),
+# so here libusb-0.1 is removed completely instead of adding virtual/libusb0.
+# Besides, libusb-0.1 uses a per 1ms polling that hurts a lot to power
+# consumption.
+PROVIDES = "libusb"
+
+PE = "1"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-${PV}.tar.bz2 \
+ file://0.1.0-beta1-gcc3.4-fix.patch"
+
+inherit autotools pkgconfig binconfig
diff --git a/meta/packages/libusb/libusb/configure_fix.patch b/meta/packages/libusb/libusb/configure_fix.patch
deleted file mode 100644
index f01f0143f..000000000
--- a/meta/packages/libusb/libusb/configure_fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-For some reason libtool 2.2.2 can't cope with this, LT_LANG(C++) works though.
-
-RP - 14/4/08
-
-Index: libusb-0.1.12/configure.in
-===================================================================
---- libusb-0.1.12.orig/configure.in 2008-04-14 22:08:26.000000000 +0100
-+++ libusb-0.1.12/configure.in 2008-04-14 22:09:43.000000000 +0100
-@@ -149,7 +149,7 @@
- fi
-
- # Checks for programs.
--AC_LANG_CPLUSPLUS
-+AC_PROG_CXX
- AC_PROG_CC
- AM_PROG_CC_C_O
- AC_PROG_INSTALL
diff --git a/meta/packages/libusb/libusb_0.1.12.bb b/meta/packages/libusb/libusb_0.1.12.bb
deleted file mode 100644
index f40d32fe9..000000000
--- a/meta/packages/libusb/libusb_0.1.12.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "libusb is a library to provide userspace \
-access to USB devices. This is 0.1 legacy version"
-HOMEPAGE = "http://www.libusb.org"
-SECTION = "libs"
-
-# usb.h.in and usb.h.in are under dual license of LGPL|BSD
-# COPYING is presented as LGPLv2.1+ but not used
-
-LICENSE = "LGPLv2+ & ( LGPLv2+ | BSD )"
-LICENSE_libusb = "LGPLv2+"
-LICENSE_libusb-dev = "LGPLv2+ | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423"
-PR = "r5"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.gz \
- file://configure_fix.patch;apply=yes"
-
-inherit autotools pkgconfig binconfig lib_package
-
-PARALLEL_MAKE = ""
-EXTRA_OECONF = "--disable-build-docs"
-
-export CXXFLAGS += "-lstdc++"
-
-PACKAGES =+ "libusbpp"
-
-FILES_libusbpp = "${libdir}/libusbpp*.so.*"
-
-BBCLASSEXTEND = "native"