summaryrefslogtreecommitdiff
path: root/meta/packages/libxml
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-05 17:37:52 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-13 12:15:26 +0000
commit7541841b565be0b1ad2238b851b7ac736e48d762 (patch)
tree388bb3b86dc8d9691dbcc35eb04c34fa02ff7043 /meta/packages/libxml
parentb9cac51c380ed55a00fa522334fb90aa547e03f6 (diff)
downloadopenembedded-core-7541841b565be0b1ad2238b851b7ac736e48d762.tar.gz
openembedded-core-7541841b565be0b1ad2238b851b7ac736e48d762.tar.bz2
openembedded-core-7541841b565be0b1ad2238b851b7ac736e48d762.tar.xz
openembedded-core-7541841b565be0b1ad2238b851b7ac736e48d762.zip
libxml2: Convert to BBCLASSEXTEND (and drop unneeded custom staging function
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/libxml')
-rw-r--r--meta/packages/libxml/libxml2-native_2.6.29.bb13
-rw-r--r--meta/packages/libxml/libxml2.inc18
-rw-r--r--meta/packages/libxml/libxml2/libxml-64bit.patch (renamed from meta/packages/libxml/files/libxml-64bit.patch)0
-rw-r--r--meta/packages/libxml/libxml2/libxml-nanohttp.patch (renamed from meta/packages/libxml/files/libxml-nanohttp.patch)0
-rw-r--r--meta/packages/libxml/libxml2_2.6.29.bb25
5 files changed, 19 insertions, 37 deletions
diff --git a/meta/packages/libxml/libxml2-native_2.6.29.bb b/meta/packages/libxml/libxml2-native_2.6.29.bb
deleted file mode 100644
index 75169f2bc..000000000
--- a/meta/packages/libxml/libxml2-native_2.6.29.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require libxml2.inc
-
-PR = "r8"
-
-DEPENDS += "python-native"
-
-EXTRA_OECONF = "--with-python=${STAGING_DIR_NATIVE}/${prefix} --without-debug --without-legacy --with-catalog --without-docbook --with-c14n"
-
-inherit native
-
-do_stage () {
- oe_runmake install
-}
diff --git a/meta/packages/libxml/libxml2.inc b/meta/packages/libxml/libxml2.inc
index e8b03cf02..1aa7132ce 100644
--- a/meta/packages/libxml/libxml2.inc
+++ b/meta/packages/libxml/libxml2.inc
@@ -7,6 +7,24 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
file://libxml-64bit.patch;patch=1 \
file://libxml-nanohttp.patch;patch=1"
+DEPENDS_virtclass-native = "python-native"
+
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_DIR_NATIVE}/${prefix} --without-debug --without-legacy --with-catalog --without-docbook --with-c14n"
+
+export LDFLAGS += "-ldl"
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/packages/libxml/files/libxml-64bit.patch b/meta/packages/libxml/libxml2/libxml-64bit.patch
index fcb7d34fa..fcb7d34fa 100644
--- a/meta/packages/libxml/files/libxml-64bit.patch
+++ b/meta/packages/libxml/libxml2/libxml-64bit.patch
diff --git a/meta/packages/libxml/files/libxml-nanohttp.patch b/meta/packages/libxml/libxml2/libxml-nanohttp.patch
index 550e036db..550e036db 100644
--- a/meta/packages/libxml/files/libxml-nanohttp.patch
+++ b/meta/packages/libxml/libxml2/libxml-nanohttp.patch
diff --git a/meta/packages/libxml/libxml2_2.6.29.bb b/meta/packages/libxml/libxml2_2.6.29.bb
index 2f583c2c3..42253dd47 100644
--- a/meta/packages/libxml/libxml2_2.6.29.bb
+++ b/meta/packages/libxml/libxml2_2.6.29.bb
@@ -1,26 +1,3 @@
require libxml2.inc
-PR = "r7"
-
-export LDFLAGS += "-ldl"
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_DATADIR}/aclocal/
- install -d ${STAGING_BINDIR_CROSS}
-
- install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
- #this is need it by php during its install
- install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
-}
-
-python populate_packages_prepend () {
- # autonamer would call this libxml2-2, but we don't want that
- if bb.data.getVar('DEBIAN_NAMES', d, 1):
- bb.data.setVar('PKG_libxml2', 'libxml2', d)
-}
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/*"
+PR = "r8"