summaryrefslogtreecommitdiff
path: root/meta/packages/libxslt/libxslt_1.1.20.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-08-02 11:30:51 +0000
committerRoss Burton <ross@openedhand.com>2007-08-02 11:30:51 +0000
commit22c85055348c01f86dffbe926a0eccf8fac3b1f9 (patch)
treea0e441d0a3d52995d063e9309d0dc80bfe922658 /meta/packages/libxslt/libxslt_1.1.20.bb
parenta2defd4d88e300d8d272cecc68cb8a55fd08cbce (diff)
downloadopenembedded-core-22c85055348c01f86dffbe926a0eccf8fac3b1f9.tar.gz
openembedded-core-22c85055348c01f86dffbe926a0eccf8fac3b1f9.tar.bz2
openembedded-core-22c85055348c01f86dffbe926a0eccf8fac3b1f9.tar.xz
openembedded-core-22c85055348c01f86dffbe926a0eccf8fac3b1f9.zip
Upgrade libxml/libxslt
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2328 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxslt/libxslt_1.1.20.bb')
-rw-r--r--meta/packages/libxslt/libxslt_1.1.20.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/packages/libxslt/libxslt_1.1.20.bb b/meta/packages/libxslt/libxslt_1.1.20.bb
new file mode 100644
index 000000000..fa063142b
--- /dev/null
+++ b/meta/packages/libxslt/libxslt_1.1.20.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR}/${HOST_SYS}," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR}/${HOST_SYS}," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
+ chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"