summaryrefslogtreecommitdiff
path: root/meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-01 10:39:58 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-01 10:39:58 +0000
commita1ffa5a168286e939d8a92ffa62f698e8c6bfc95 (patch)
treefb180a69297e5d5b636c096ef61236f58c1b68c7 /meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch
parentf217220fd5faebd1d746084e6e9d302c64916996 (diff)
downloadopenembedded-core-a1ffa5a168286e939d8a92ffa62f698e8c6bfc95.tar.gz
openembedded-core-a1ffa5a168286e939d8a92ffa62f698e8c6bfc95.tar.bz2
openembedded-core-a1ffa5a168286e939d8a92ffa62f698e8c6bfc95.tar.xz
openembedded-core-a1ffa5a168286e939d8a92ffa62f698e8c6bfc95.zip
linux-rp-2.6.23: Make qemuarm and qemux86 use 2.6.23, sync .bb file with OE for poodle and tosa changes.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3394 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch')
-rw-r--r--meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch b/meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch
new file mode 100644
index 000000000..b5439c62e
--- /dev/null
+++ b/meta/packages/linux/linux-rp-2.6.23/connectplus-prevent-oops-HACK.patch
@@ -0,0 +1,17 @@
+Index: linux-2.6.21/drivers/net/wireless/hostap/hostap_hw.c
+===================================================================
+--- linux-2.6.21.orig/drivers/net/wireless/hostap/hostap_hw.c 2007-07-07 12:45:39.000000000 +0100
++++ linux-2.6.21/drivers/net/wireless/hostap/hostap_hw.c 2007-07-07 12:47:30.000000000 +0100
+@@ -2666,6 +2666,12 @@
+ iface = netdev_priv(dev);
+ local = iface->local;
+
++ if(dev->base_addr == 0)
++ {
++ printk(KERN_DEBUG "%s: IRQ before base_addr set\n", dev->name);
++ return IRQ_HANDLED;
++ }
++
+ prism2_io_debug_add(dev, PRISM2_IO_DEBUG_CMD_INTERRUPT, 0, 0);
+
+ if (local->func->card_present && !local->func->card_present(local)) {