summaryrefslogtreecommitdiff
path: root/meta/packages/linux/linux-rp-2.6.26
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 11:26:05 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 11:26:05 +0000
commit50e3ea738d7c73b155072538f63d78df1d9177a4 (patch)
treee7ebb7d23a6fa346917969093b7429c6a9c71d65 /meta/packages/linux/linux-rp-2.6.26
parent44abf32a27b3b69f26c694d1d4b60edc15f0db33 (diff)
downloadopenembedded-core-50e3ea738d7c73b155072538f63d78df1d9177a4.tar.gz
openembedded-core-50e3ea738d7c73b155072538f63d78df1d9177a4.tar.bz2
openembedded-core-50e3ea738d7c73b155072538f63d78df1d9177a4.tar.xz
openembedded-core-50e3ea738d7c73b155072538f63d78df1d9177a4.zip
linux-rp: added armv7a fix from linux-omap to make qemuarmv7 build
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4926 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux/linux-rp-2.6.26')
-rw-r--r--meta/packages/linux/linux-rp-2.6.26/fixes.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-rp-2.6.26/fixes.patch b/meta/packages/linux/linux-rp-2.6.26/fixes.patch
new file mode 100644
index 000000000..5df21d5fa
--- /dev/null
+++ b/meta/packages/linux/linux-rp-2.6.26/fixes.patch
@@ -0,0 +1,38 @@
+Index: git/arch/arm/Makefile
+===================================================================
+--- git.orig/arch/arm/Makefile 2008-06-13 13:10:59.000000000 +0100
++++ git/arch/arm/Makefile 2008-07-19 10:31:31.000000000 +0100
+@@ -47,7 +47,7 @@
+ # Note that GCC does not numerically define an architecture version
+ # macro, but instead defines a whole series of macros which makes
+ # testing for a specific architecture or later rather impossible.
+-arch-$(CONFIG_CPU_32v7) :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7a,-march=armv5t -Wa$(comma)-march=armv7a)
++arch-$(CONFIG_CPU_32v7) :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7-a,-march=armv5t -Wa$(comma)-march=armv7-a)
+ arch-$(CONFIG_CPU_32v6) :=-D__LINUX_ARM_ARCH__=6 $(call cc-option,-march=armv6,-march=armv5t -Wa$(comma)-march=armv6)
+ # Only override the compiler option if ARMv6. The ARMv6K extensions are
+ # always available in ARMv7
+Index: git/include/asm-arm/processor.h
+===================================================================
+--- git.orig/include/asm-arm/processor.h 2008-06-13 13:12:19.000000000 +0100
++++ git/include/asm-arm/processor.h 2008-07-19 10:31:31.000000000 +0100
+@@ -109,14 +109,16 @@
+ #if __LINUX_ARM_ARCH__ >= 5
+
+ #define ARCH_HAS_PREFETCH
+-static inline void prefetch(const void *ptr)
++#define prefetch(ptr) __builtin_prefetch(ptr)
++
++/*static inline void prefetch(const void *ptr)
+ {
+ __asm__ __volatile__(
+- "pld\t%0"
++ "pld\ta%0"
+ :
+- : "o" (*(char *)ptr)
++ : "p" (ptr)
+ : "cc");
+-}
++}*/
+
+ #define ARCH_HAS_PREFETCHW
+ #define prefetchw(ptr) prefetch(ptr)