summaryrefslogtreecommitdiff
path: root/meta/packages/linux
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-23 15:22:08 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-23 15:22:08 +0000
commitb48c1aca8b7af98682f5b255e15b2fd22333a7b5 (patch)
tree1432d64ababd29e170c57e9186976ac11fb4c88b /meta/packages/linux
parentf9ad5a0f7a20c864c8d473aea72a6ba3ae7900e2 (diff)
downloadopenembedded-core-b48c1aca8b7af98682f5b255e15b2fd22333a7b5.tar.gz
openembedded-core-b48c1aca8b7af98682f5b255e15b2fd22333a7b5.tar.bz2
openembedded-core-b48c1aca8b7af98682f5b255e15b2fd22333a7b5.tar.xz
openembedded-core-b48c1aca8b7af98682f5b255e15b2fd22333a7b5.zip
linux-nokia800: Add oprofile mismatch workaround, update to osso40
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1770 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux')
-rw-r--r--meta/packages/linux/linux-nokia800-2.6.18-osso40/fix_oprofile.patch30
-rw-r--r--meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia770/defconfig (renamed from meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia770/defconfig)0
-rw-r--r--meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia800/defconfig (renamed from meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia800/defconfig)16
-rw-r--r--meta/packages/linux/linux-nokia800_2.6.18-osso40.bb (renamed from meta/packages/linux/linux-nokia800_2.6.18-osso29.bb)7
4 files changed, 43 insertions, 10 deletions
diff --git a/meta/packages/linux/linux-nokia800-2.6.18-osso40/fix_oprofile.patch b/meta/packages/linux/linux-nokia800-2.6.18-osso40/fix_oprofile.patch
new file mode 100644
index 000000000..c5849998d
--- /dev/null
+++ b/meta/packages/linux/linux-nokia800-2.6.18-osso40/fix_oprofile.patch
@@ -0,0 +1,30 @@
+---
+ arch/arm/oprofile/op_model_v6.c | 8 +-------
+ 1 file changed, 1 insertion(+), 7 deletions(-)
+
+Index: linux-g/arch/arm/oprofile/op_model_v6.c
+===================================================================
+--- linux-g.orig/arch/arm/oprofile/op_model_v6.c 2006-11-08 12:18:41.000000000 +0000
++++ linux-g/arch/arm/oprofile/op_model_v6.c 2007-05-23 14:11:19.000000000 +0100
+@@ -54,12 +54,6 @@
+ #define EVT_DCACHE_MISS 0x0B
+ #define EVT_DCACE_WRITE_BACK 0x0C
+ #define EVT_PC_CHANGED 0x0D
+-#define EVT_BCU_REQUEST 0x10
+-#define EVT_BCU_FULL 0x11
+-#define EVT_BCU_DRAIN 0x12
+-#define EVT_BCU_ECC_NO_ELOG 0x14
+-#define EVT_BCU_1_BIT_ERR 0x15
+-#define EVT_RMW 0x16
+ /* EVT_CCNT is not hardware defined */
+ #define EVT_CCNT 0xFE
+ #define EVT_UNUSED 0xFF
+@@ -88,7 +82,7 @@ struct pmu_type {
+ static struct pmu_type pmu_parms[] = {
+ {
+ .id = PMU_ARM11,
+- .name = "arm/arm11",
++ .name = "arm/armv6",
+ .num_counters = 3,
+ #ifdef CONFIG_ARCH_OMAP2
+ .interrupt = 3,
diff --git a/meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia770/defconfig b/meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia770/defconfig
index ef33d828c..ef33d828c 100644
--- a/meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia770/defconfig
+++ b/meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia770/defconfig
diff --git a/meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia800/defconfig b/meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia800/defconfig
index 328b90010..c96a55dea 100644
--- a/meta/packages/linux/linux-nokia800-2.6.18-osso29/nokia800/defconfig
+++ b/meta/packages/linux/linux-nokia800-2.6.18-osso40/nokia800/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.18-omap1
-# Tue Nov 14 20:41:41 2006
+# Wed May 23 16:23:22 2007
#
CONFIG_ARM=y
CONFIG_MMU=y
@@ -712,15 +712,13 @@ CONFIG_HW_CONSOLE=y
#
# Serial drivers
#
-CONFIG_SERIAL_8250=y
-CONFIG_SERIAL_8250_CONSOLE=y
-CONFIG_SERIAL_8250_NR_UARTS=4
-CONFIG_SERIAL_8250_RUNTIME_UARTS=4
-# CONFIG_SERIAL_8250_EXTENDED is not set
+# CONFIG_SERIAL_8250 is not set
#
# Non-8250 serial port support
#
+CONFIG_SERIAL_OMAP=y
+CONFIG_SERIAL_OMAP_CONSOLE=y
CONFIG_SERIAL_CORE=y
CONFIG_SERIAL_CORE_CONSOLE=y
CONFIG_UNIX98_PTYS=y
@@ -1168,11 +1166,13 @@ CONFIG_JFFS2_SUMMARY=y
# CONFIG_JFFS2_FS_XATTR is not set
CONFIG_JFFS2_COMPRESSION_OPTIONS=y
CONFIG_JFFS2_ZLIB=y
+CONFIG_JFFS2_LZO=y
CONFIG_JFFS2_RTIME=y
# CONFIG_JFFS2_RUBIN is not set
# CONFIG_JFFS2_CMODE_NONE is not set
CONFIG_JFFS2_CMODE_PRIORITY=y
# CONFIG_JFFS2_CMODE_SIZE is not set
+# CONFIG_JFFS2_CMODE_FAVOURLZO is not set
# CONFIG_CRAMFS is not set
# CONFIG_VXFS_FS is not set
# CONFIG_HPFS_FS is not set
@@ -1245,7 +1245,8 @@ CONFIG_NLS_UTF8=y
#
# Profiling support
#
-# CONFIG_PROFILING is not set
+CONFIG_PROFILING=y
+CONFIG_OPROFILE=y
#
# Kernel hacking
@@ -1305,6 +1306,7 @@ CONFIG_CRC_CCITT=y
# CONFIG_CRC16 is not set
CONFIG_CRC32=y
# CONFIG_LIBCRC32C is not set
+CONFIG_LZO=y
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y
CONFIG_PLIST=y
diff --git a/meta/packages/linux/linux-nokia800_2.6.18-osso29.bb b/meta/packages/linux/linux-nokia800_2.6.18-osso40.bb
index 6b128113b..b8ae6f70c 100644
--- a/meta/packages/linux/linux-nokia800_2.6.18-osso29.bb
+++ b/meta/packages/linux/linux-nokia800_2.6.18-osso40.bb
@@ -1,13 +1,14 @@
require linux-nokia800.inc
-PR = "r3"
-SRC_URI = "http://repository.maemo.org/pool/maemo3.0/free/source/kernel-source-rx-34_2.6.18.orig.tar.gz \
- http://repository.maemo.org/pool/maemo3.0/free/source/kernel-source-rx-34_2.6.18-osso29.diff.gz;patch=1 \
+PR = "r0"
+SRC_URI = "http://repository.maemo.org/pool/maemo3.1/free/source/kernel-source-rx-34_2.6.18.orig.tar.gz \
+ http://repository.maemo.org/pool/maemo3.1/free/source/kernel-source-rx-34_2.6.18-osso40.diff.gz;patch=1 \
${RPSRC}/lzo_kernel-r0.patch;patch=1 \
${RPSRC}/lzo_jffs2-r0.patch;patch=1 \
${RPSRC}/lzo_crypto-r0b.patch;patch=1 \
${RPSRC}/lzo_jffs2_lzomode-r0.patch;patch=1 \
${RPSRC}/lzo_jffs2_sysfs-r0.patch;patch=1 \
+ file://fix_oprofile.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/linux-g"