summaryrefslogtreecommitdiff
path: root/meta/packages/lsof/lsof_4.77.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-06 11:19:13 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-06 11:19:13 +0000
commit03b90cc5baa384b66d13436743f92e7162603af9 (patch)
treecf0dc1212349ad88e5abca3f2a96cd90f0c183d0 /meta/packages/lsof/lsof_4.77.bb
parent62e66ef22dbba6d08ac8e35cc2eeeb7463020658 (diff)
downloadopenembedded-core-03b90cc5baa384b66d13436743f92e7162603af9.tar.gz
openembedded-core-03b90cc5baa384b66d13436743f92e7162603af9.tar.bz2
openembedded-core-03b90cc5baa384b66d13436743f92e7162603af9.tar.xz
openembedded-core-03b90cc5baa384b66d13436743f92e7162603af9.zip
lsof: update to 4.77 (from OE) as 4.75 is not available upstream
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1448 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof/lsof_4.77.bb')
-rw-r--r--meta/packages/lsof/lsof_4.77.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/lsof/lsof_4.77.bb b/meta/packages/lsof/lsof_4.77.bb
new file mode 100644
index 000000000..054875b86
--- /dev/null
+++ b/meta/packages/lsof/lsof_4.77.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
+Its name stands for LiSt Open Files, and it does just that."
+SECTION = "devel"
+LICENSE = "BSD"
+PR = "r1"
+
+SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
+LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
+S = "${WORKDIR}/lsof_${PV}_src"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
+ bb.build.exec_func('base_do_unpack', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+}
+
+LSOF_OS = "${TARGET_OS}"
+LSOF_OS_linux-uclibc = "linux"
+LSOF_OS_linux-gnueabi = "linux"
+
+do_configure () {
+ yes | ./Configure ${LSOF_OS}
+}
+
+export I = "${STAGING_INCDIR}"
+export L = "${STAGING_INCDIR}"
+export EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${mandir}/man8
+ install -m 4755 lsof ${D}${sbindir}/lsof
+ install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
+}