summaryrefslogtreecommitdiff
path: root/meta/packages/lsof
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-08 16:37:40 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-08 16:37:40 +0000
commit121b39d4a88c88c099ed8f9f6fa1f254efbc9b03 (patch)
tree90d8f30055abdec184a4a7893a5ffe94b4e2f510 /meta/packages/lsof
parent2ce9dd1cb0fe8b1128b4403b9c09d2d705e3c90a (diff)
downloadopenembedded-core-121b39d4a88c88c099ed8f9f6fa1f254efbc9b03.tar.gz
openembedded-core-121b39d4a88c88c099ed8f9f6fa1f254efbc9b03.tar.bz2
openembedded-core-121b39d4a88c88c099ed8f9f6fa1f254efbc9b03.tar.xz
openembedded-core-121b39d4a88c88c099ed8f9f6fa1f254efbc9b03.zip
Add lsof 0.78 from OE with build fixes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2398 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof')
-rw-r--r--meta/packages/lsof/lsof_4.78.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/lsof/lsof_4.78.bb b/meta/packages/lsof/lsof_4.78.bb
new file mode 100644
index 000000000..51f0b8b2c
--- /dev/null
+++ b/meta/packages/lsof/lsof_4.78.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
+Its name stands for LiSt Open Files, and it does just that."
+SECTION = "devel"
+LICENSE = "BSD"
+
+SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
+LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
+S = "${WORKDIR}/lsof_${PV}_src"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
+ bb.build.exec_func('base_do_unpack', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+}
+
+export LSOF_OS = "${TARGET_OS}"
+LSOF_OS_linux-uclibc = "linux"
+LSOF_OS_linux-gnueabi = "linux"
+export LSOF_INCLUDE = "${STAGING_INCDIR}"
+
+do_configure () {
+ yes | ./Configure ${LSOF_OS}
+}
+
+export I = "${STAGING_INCDIR}"
+export L = "${STAGING_INCDIR}"
+export EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${mandir}/man8
+ install -m 4755 lsof ${D}${sbindir}/lsof
+ install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
+}