summaryrefslogtreecommitdiff
path: root/meta/packages/mesa/mesa-dri_7.8.2.bb
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-08-02 20:24:09 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-02 16:33:51 +0100
commitd9b1d4312cf1f981c5201b027b18594e9ad5a861 (patch)
treedf639a4e0a4cf031777c04477ddcf523e4b03a4f /meta/packages/mesa/mesa-dri_7.8.2.bb
parenta235e4195eed3e5c21f458c24f0964c8d5abb740 (diff)
downloadopenembedded-core-d9b1d4312cf1f981c5201b027b18594e9ad5a861.tar.gz
openembedded-core-d9b1d4312cf1f981c5201b027b18594e9ad5a861.tar.bz2
openembedded-core-d9b1d4312cf1f981c5201b027b18594e9ad5a861.tar.xz
openembedded-core-d9b1d4312cf1f981c5201b027b18594e9ad5a861.zip
mesa-dri: fix x86-64 target compilation
mesa-dri first generates glsl compiler and then use it to compile GL shader sources. Target glsl compiler can't run on build system, and thus port from openembedded by introducing a native recipe dedicated to creating a native glsl-compiler. This has to be an explicit -native recipe since its un-native sibling is already part of mesa-dri Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/mesa/mesa-dri_7.8.2.bb')
-rw-r--r--meta/packages/mesa/mesa-dri_7.8.2.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta/packages/mesa/mesa-dri_7.8.2.bb b/meta/packages/mesa/mesa-dri_7.8.2.bb
index 6c8c824fa..ffd885f29 100644
--- a/meta/packages/mesa/mesa-dri_7.8.2.bb
+++ b/meta/packages/mesa/mesa-dri_7.8.2.bb
@@ -5,9 +5,9 @@ LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1
PROTO_DEPS = "xf86driproto glproto dri2proto"
LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
-DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native"
-PR = "r0"
+PR = "r1"
SRC_URI += "file://crossfix.patch"
@@ -21,9 +21,14 @@ LEAD_SONAME = "libGL.so.1"
EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
+# We need glsl-compile built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+do_configure_prepend() {
+ sed -i "s#^GLSL_CL = .*\$#GLSL_CL = ${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/Makefile
+}
+
do_install_append () {
- install -d ${D}/usr/bin
- install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
}
python populate_packages_prepend() {