summaryrefslogtreecommitdiff
path: root/meta/packages/modutils/modutils-collateral.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 11:25:09 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 11:25:09 +0000
commit2fe7cc5f9fdacc4321bddcbf132e32ddea21f59b (patch)
treed404fc85e11ffb191167d694a47182df6d3ee51b /meta/packages/modutils/modutils-collateral.bb
parent52e92fdd15b5c6a04d8afeb36f843218ceda8bf8 (diff)
downloadopenembedded-core-2fe7cc5f9fdacc4321bddcbf132e32ddea21f59b.tar.gz
openembedded-core-2fe7cc5f9fdacc4321bddcbf132e32ddea21f59b.tar.bz2
openembedded-core-2fe7cc5f9fdacc4321bddcbf132e32ddea21f59b.tar.xz
openembedded-core-2fe7cc5f9fdacc4321bddcbf132e32ddea21f59b.zip
packages/modutils/modutils-collateral.bb: Modprobe has changed between 2.4 and 2.6 kernels. (sync with OE)
The information in /etc/modutils and /etc/modules.conf is not read under 2.6. 2.6 uses a /etc/modprobe.d directory, and it does not need a "/etc/modprobe.conf" file; it reads all the appropriate *.conf files and compiles the information at boot time. This commit closes bug #808 git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2993 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/modutils/modutils-collateral.bb')
-rw-r--r--meta/packages/modutils/modutils-collateral.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/packages/modutils/modutils-collateral.bb b/meta/packages/modutils/modutils-collateral.bb
index 5c502021f..6d010a575 100644
--- a/meta/packages/modutils/modutils-collateral.bb
+++ b/meta/packages/modutils/modutils-collateral.bb
@@ -1,6 +1,6 @@
SECTION = "base"
DESCRIPTION = "modutils configuration files"
-PR = "r2"
+PR = "r3"
LICENSE = "MIT"
SRC_URI = "file://modules \
@@ -12,5 +12,10 @@ do_compile () {
do_install () {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/modules ${D}${sysconfdir}/modules
- install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+ if [ ${MAJOR_KERNEL_VERSION}=2.6 ]; then
+ install -d ${D}${sysconfdir}/modprobe.d
+ else
+ install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+ fi
+
}