summaryrefslogtreecommitdiff
path: root/meta/packages/mutter/mutter_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-07-07 13:57:52 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-07-07 13:57:52 +0100
commitb2112e9f85ada538fdb2360d9c834e98da5d2072 (patch)
tree82e26f611519413fdb14e68bc355be4b40f0aeba /meta/packages/mutter/mutter_git.bb
parent87de4bd5c72819f8a32df77d172752d73909dd09 (diff)
downloadopenembedded-core-b2112e9f85ada538fdb2360d9c834e98da5d2072.tar.gz
openembedded-core-b2112e9f85ada538fdb2360d9c834e98da5d2072.tar.bz2
openembedded-core-b2112e9f85ada538fdb2360d9c834e98da5d2072.tar.xz
openembedded-core-b2112e9f85ada538fdb2360d9c834e98da5d2072.zip
mutter: Update after recent upstream changes and renaming
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mutter/mutter_git.bb')
-rw-r--r--meta/packages/mutter/mutter_git.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb
index 7a0e87d1b..cebdc7cf0 100644
--- a/meta/packages/mutter/mutter_git.bb
+++ b/meta/packages/mutter/mutter_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutte
LICENSE = "GPLv2"
DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native intltool glib-2.0-native"
# gobject-introspection
-PR = "r9"
+PR = "r10"
PV = "2.25.1+git${SRCPV}"
inherit gnome update-alternatives
@@ -13,13 +13,15 @@ inherit gnome update-alternatives
SRC_URI = "git://git.moblin.org/mutter.git;protocol=git;branch=master \
file://nodocs.patch;patch=1 \
file://nozenity.patch;patch=1 \
- file://crosscompile.patch;patch=1 \
- file://fix_pkgconfig.patch;patch=1"
+ file://crosscompile.patch;patch=1;rev=7adb574bb3fa3880eb85dbc86e580cf3452d57c4 \
+ file://fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch;patch=1;rev=7adb574bb3fa3880eb85dbc86e580cf3452d57c4 \
+ file://fix_pkgconfig.patch;patch=1;notrev=7adb574bb3fa3880eb85dbc86e580cf3452d57c4 \
+ "
S = "${WORKDIR}/git"
ALTERNATIVE_NAME = "x-window-manager"
ALTERNATIVE_LINK = "${bindir}/x-window-manager"
-ALTERNATIVE_PATH = "${bindir}/metacity"
+ALTERNATIVE_PATH = "${bindir}/mutter"
ALTERNATIVE_PRIORITY = "11"
EXTRA_OECONF += "--disable-verbose \
@@ -29,8 +31,8 @@ EXTRA_OECONF += "--disable-verbose \
#RDEPENDS_${PN} = "zenity"
-FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so"
-FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
+FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/"
+FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*"
export CC_FOR_BUILD = "${BUILD_CC}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include"
@@ -52,8 +54,8 @@ fi
. ${sysconfdir}/init.d/functions
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[default]'
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]'
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/metacity/general/compositing_manager true
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true
}