summaryrefslogtreecommitdiff
path: root/meta/packages/nfs-utils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/nfs-utils
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.bz2
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.xz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.zip
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/nfs-utils')
-rw-r--r--meta/packages/nfs-utils/libnfsidmap_0.23.bb13
-rw-r--r--meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch18
-rw-r--r--meta/packages/nfs-utils/nfs-utils/nfsserver161
-rw-r--r--meta/packages/nfs-utils/nfs-utils_1.2.2.bb51
4 files changed, 0 insertions, 243 deletions
diff --git a/meta/packages/nfs-utils/libnfsidmap_0.23.bb b/meta/packages/nfs-utils/libnfsidmap_0.23.bb
deleted file mode 100644
index c6b02fe19..000000000
--- a/meta/packages/nfs-utils/libnfsidmap_0.23.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "nfs idmapping library"
-HOMEPAGE = "http://www.citi.umich.edu/projects/nfsv4/linux/"
-SECTION = "libs"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d9c6a2a0ca6017fda7cd905ed2739b37"
-PR = "r0"
-
-SRC_URI = "http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${BPN}-${PV}.tar.gz"
-
-inherit autotools
-
-EXTRA_OECONF = "--disable-ldap"
diff --git a/meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch b/meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch
deleted file mode 100644
index 336dc0e26..000000000
--- a/meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./support/nfs/svc_socket.c.orig 2004-12-12 06:43:52.000000000 +0000
-+++ ./support/nfs/svc_socket.c 2004-12-12 06:50:04.000000000 +0000
-@@ -66,6 +66,7 @@
- memset ((char *) &addr, sizeof (addr));
- addr.sin_family = AF_INET;
-
-+#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
- ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,
- &rpcp);
- if (ret == 0 && rpcp != NULL)
-@@ -99,6 +100,7 @@
- }
- }
- else
-+#endif
- {
- if (bindresvport (sock, &addr))
- {
diff --git a/meta/packages/nfs-utils/nfs-utils/nfsserver b/meta/packages/nfs-utils/nfs-utils/nfsserver
deleted file mode 100644
index 9d02e8584..000000000
--- a/meta/packages/nfs-utils/nfs-utils/nfsserver
+++ /dev/null
@@ -1,161 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: nfs-kernel-server
-# Required-Start: $remote_fs $portmap hwclock
-# Required-Stop: $remote_fs $portmap hwclock
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Kernel NFS server support
-# Description: NFS is a popular protocol for file sharing across
-# TCP/IP networks. This service provides NFS server
-# functionality, which is configured via the
-# /etc/exports file.
-### END INIT INFO
-#
-# Startup script for nfs-utils
-#
-#
-# The environment variable NFS_SERVERS may be set in /etc/default/nfsd
-# Other control variables may be overridden here too
-test -r /etc/default/nfsd && . /etc/default/nfsd
-#
-# Location of executables:
-test -x "$NFS_MOUNTD" || NFS_MOUNTD=/usr/sbin/mountd
-test -x "$NFS_NFSD" || NFS_NFSD=/usr/sbin/nfsd
-test -x "$NFS_STATD" || NFS_STATD=/usr/sbin/statd
-#
-# The user mode program must also exist (it just starts the kernel
-# threads using the kernel module code).
-test -x "$NFS_MOUNTD" || exit 0
-test -x "$NFS_NFSD" || exit 0
-#
-# Default is 8 threads, value is settable between 1 and the truely
-# ridiculous 99
-test "$NFS_SERVERS" -gt 0 && test "$NFS_SERVERS" -lt 100 || NFS_SERVERS=8
-#
-# The default state directory is /var/lib/nfs
-test -n "$NFS_STATEDIR" || NFS_STATEDIR=/var/lib/nfs
-#
-#----------------------------------------------------------------------
-# Startup and shutdown functions.
-# Actual startup/shutdown is at the end of this file.
-#directories
-create_directories(){
- echo -n 'creating NFS state directory: '
- mkdir -p "$NFS_STATEDIR"
- ( cd "$NFS_STATEDIR"
- umask 077
- mkdir -p sm sm.bak
- test -w sm/state || {
- rm -f sm/state
- :>sm/state
- }
- umask 022
- for file in xtab etab smtab rmtab
- do
- test -w "$file" || {
- rm -f "$file"
- :>"$file"
- }
- done
- )
- echo done
-}
-#mountd
-start_mountd(){
- echo -n 'starting mountd: '
- start-stop-daemon --start --exec "$NFS_MOUNTD" -- "-f /etc/exports $@"
- echo done
-}
-stop_mountd(){
- echo -n 'stopping mountd: '
- start-stop-daemon --stop --quiet --exec "$NFS_MOUNTD"
- echo done
-}
-#
-#nfsd
-start_nfsd(){
- echo -n "starting $1 nfsd kernel threads: "
- start-stop-daemon --start --exec "$NFS_NFSD" -- "$@"
- echo done
-}
-delay_nfsd(){
- for delay in 0 1 2 3 4 5 6 7 8 9
- do
- if pidof nfsd >/dev/null
- then
- echo -n .
- sleep 1
- else
- return 0
- fi
- done
- return 1
-}
-stop_nfsd(){
- # WARNING: this kills any process with the executable
- # name 'nfsd'.
- echo -n 'stopping nfsd: '
- start-stop-daemon --stop --quiet --signal 1 --name nfsd
- if delay_nfsd || {
- echo failed
- echo ' using signal 9: '
- start-stop-daemon --stop --quiet --signal 9 --name nfsd
- delay_nfsd
- }
- then
- echo done
- # This will remove, recursively, dependencies
- echo -n 'removing nfsd kernel module: '
- if modprobe -r nfsd
- then
- echo done
- else
- echo failed
- fi
- else
- echo failed
- fi
-}
-
-#statd
-start_statd(){
- echo -n "starting statd: "
- start-stop-daemon --start --exec "$NFS_STATD"
- echo done
-}
-stop_statd(){
- # WARNING: this kills any process with the executable
- # name 'statd'.
- echo -n 'stopping statd: '
- start-stop-daemon --stop --quiet --signal 1 --name statd
- echo done
-}
-#----------------------------------------------------------------------
-#
-# supported options:
-# start
-# stop
-# reload: reloads the exports file
-# restart: stops and starts mountd
-#FIXME: need to create the /var/lib/nfs/... directories
-case "$1" in
-start) create_directories
- start_nfsd "$NFS_SERVERS"
- start_mountd
- start_statd
- test -r /etc/exports && exportfs -a;;
-stop) exportfs -ua
- stop_statd
- stop_mountd
- stop_nfsd;;
-reload) test -r /etc/exports && exportfs -r;;
-restart)exportfs -ua
- stop_mountd
- stop_statd
- # restart does not restart the kernel threads,
- # only the user mode processes
- start_mountd
- start_statd
- test -r /etc/exports && exportfs -a;;
-esac
diff --git a/meta/packages/nfs-utils/nfs-utils_1.2.2.bb b/meta/packages/nfs-utils/nfs-utils_1.2.2.bb
deleted file mode 100644
index fafedd17b..000000000
--- a/meta/packages/nfs-utils/nfs-utils_1.2.2.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-DESCRIPTION = "userspace utilities for kernel nfs"
-HOMEPAGE = "http://nfs.sourceforge.net/"
-SECTION = "console/network"
-PRIORITY = "optional"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-
-# util-linux for libblkid
-DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
-RDEPENDS = "portmap"
-RRECOMMENDS = "kernel-module-nfsd"
-
-PR = "r1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
- file://nfs-utils-1.0.6-uclibc.patch \
- file://nfsserver"
-
-PARALLEL_MAKE = ""
-
-# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
-# pull in the remainder of the dependencies.
-
-INITSCRIPT_NAME = "nfsserver"
-# The server has no dependencies at the user run levels, so just put
-# it in at the default levels. It must be terminated before the network
-# in the shutdown levels, but that works fine.
-INITSCRIPT_PARAMS = "defaults"
-
-inherit autotools update-rc.d
-
-# --enable-uuid is need for cross-compiling
-EXTRA_OECONF = "--with-statduser=nobody \
- --enable-nfsv41 \
- --enable-uuid \
- --disable-gss \
- --disable-tirpc \
- --with-statedir=/var/lib/nfs"
-
-INHIBIT_AUTO_STAGE = "1"
-
-do_install_append () {
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
-
- # the following are built by CC_FOR_BUILD
- rm -f ${D}${sbindir}/rpcdebug
- rm -f ${D}${sbindir}/rpcgen
- rm -f ${D}${sbindir}/locktest
-}