summaryrefslogtreecommitdiff
path: root/meta/packages/oh/qemu-config.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-03-28 10:36:07 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-03-28 10:36:07 +0000
commitffd6b859368b38fc90963c72c3c86916bcdd086a (patch)
treea2b163f9d075fb007a48f22e53b48722a7fce56b /meta/packages/oh/qemu-config.bb
parentbfb887efc05bdea0fc33a0cbe6d0b69404e0ff5d (diff)
downloadopenembedded-core-ffd6b859368b38fc90963c72c3c86916bcdd086a.tar.gz
openembedded-core-ffd6b859368b38fc90963c72c3c86916bcdd086a.tar.bz2
openembedded-core-ffd6b859368b38fc90963c72c3c86916bcdd086a.tar.xz
openembedded-core-ffd6b859368b38fc90963c72c3c86916bcdd086a.zip
qemu-config: this recipe replace qemu-distcc and provide NFS exports file
- / dir is exported R/W for any host git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1397 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oh/qemu-config.bb')
-rw-r--r--meta/packages/oh/qemu-config.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/oh/qemu-config.bb b/meta/packages/oh/qemu-config.bb
new file mode 100644
index 000000000..a042725fb
--- /dev/null
+++ b/meta/packages/oh/qemu-config.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
+LICENSE = "GPL"
+RDEPENDS = "distcc"
+PR = "r1"
+
+SRC_URI = "file://distcc.sh \
+ file://exports"
+
+S = "${WORKDIR}"
+
+COMPATIBLE_MACHINE = "(qemuarm|qemux86)"
+PACKAGE_ARCH = "all"
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+
+ install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 exports ${D}${sysconfdir}
+}