summaryrefslogtreecommitdiff
path: root/meta/packages/oh
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/oh
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.bz2
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.xz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.zip
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/oh')
-rw-r--r--meta/packages/oh/qemu-config.bb36
-rw-r--r--meta/packages/oh/qemu-config/anjuta-remote-run7
-rw-r--r--meta/packages/oh/qemu-config/distcc.sh4
-rw-r--r--meta/packages/oh/qemu-config/exports1
-rwxr-xr-xmeta/packages/oh/qemu-config/qemu-autostart37
-rw-r--r--meta/packages/oh/qemu-config/qemuarm/shutdown.desktop10
-rw-r--r--meta/packages/oh/qemu-config/shutdown.desktop10
-rw-r--r--meta/packages/oh/usbinit.bb18
-rwxr-xr-xmeta/packages/oh/usbinit/usb-gether23
9 files changed, 0 insertions, 146 deletions
diff --git a/meta/packages/oh/qemu-config.bb b/meta/packages/oh/qemu-config.bb
deleted file mode 100644
index fc5932028..000000000
--- a/meta/packages/oh/qemu-config.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
-LICENSE = "GPL"
-RDEPENDS = "distcc task-poky-nfs-server oprofileui-server rsync bash"
-PR = "r17"
-
-SRC_URI = "file://distcc.sh \
- file://anjuta-remote-run \
- file://exports \
- file://shutdown.desktop \
- file://qemu-autostart"
-
-S = "${WORKDIR}"
-
-COMPATIBLE_MACHINE = "(qemuarm|qemux86)"
-PACKAGE_ARCH = "all"
-
-do_install() {
- install -d ${D}${sysconfdir}/profile.d
-
- install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
- install -m 0644 exports ${D}${sysconfdir}/
-
- install -d ${D}${bindir}
- install -m 0755 anjuta-remote-run ${D}${bindir}/
-
- install -d ${D}${datadir}/applications
- install -m 0644 shutdown.desktop ${D}${datadir}/applications/
-
- install -d ${D}/etc/init.d
- install qemu-autostart ${D}/etc/init.d/
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "qemu-autostart"
-INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
diff --git a/meta/packages/oh/qemu-config/anjuta-remote-run b/meta/packages/oh/qemu-config/anjuta-remote-run
deleted file mode 100644
index 620e3a705..000000000
--- a/meta/packages/oh/qemu-config/anjuta-remote-run
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-. /etc/profile
-export DISPLAY=:0
-dbus-launch $@
-
-
diff --git a/meta/packages/oh/qemu-config/distcc.sh b/meta/packages/oh/qemu-config/distcc.sh
deleted file mode 100644
index a2b543d6b..000000000
--- a/meta/packages/oh/qemu-config/distcc.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-DISTCC_HOSTS="192.168.7.1"
-#DISTCC_VERBOSE="1"
-
-export DISTCC_HOSTS
diff --git a/meta/packages/oh/qemu-config/exports b/meta/packages/oh/qemu-config/exports
deleted file mode 100644
index b7257aa00..000000000
--- a/meta/packages/oh/qemu-config/exports
+++ /dev/null
@@ -1 +0,0 @@
-/ *(rw,no_root_squash,async)
diff --git a/meta/packages/oh/qemu-config/qemu-autostart b/meta/packages/oh/qemu-config/qemu-autostart
deleted file mode 100755
index db2668eb4..000000000
--- a/meta/packages/oh/qemu-config/qemu-autostart
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: hddtemp
-# Required-Start: $network
-# Required-Stop: $network
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: OProfile server
-# Description:
-### END INIT INFO
-
-. /etc/init.d/functions
-
-case "$1" in
- start)
- echo "Starting automatic qemu services"
- . /etc/profile
- /usr/bin/oprofile-server &
- ;;
-
- stop)
- echo "Stopping qemu services"
- killproc oprofile-server
- ;;
-
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-
- *)
- echo "usage: $0 { start | stop | restart }"
- ;;
-esac
-
-exit 0
diff --git a/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop b/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop
deleted file mode 100644
index b973d4318..000000000
--- a/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Type=Application
-Name=Shutdown
-Comment=Close down the machine safely
-Exec=reboot
-Icon=system-shutdown
-Terminal=false
-Categories=Utility;
-StartupNotify=true \ No newline at end of file
diff --git a/meta/packages/oh/qemu-config/shutdown.desktop b/meta/packages/oh/qemu-config/shutdown.desktop
deleted file mode 100644
index 272688922..000000000
--- a/meta/packages/oh/qemu-config/shutdown.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Type=Application
-Name=Shutdown
-Comment=Close down the machine safely
-Exec=halt
-Icon=system-shutdown
-Terminal=false
-Categories=Utility;
-StartupNotify=true \ No newline at end of file
diff --git a/meta/packages/oh/usbinit.bb b/meta/packages/oh/usbinit.bb
deleted file mode 100644
index 1d4575bdd..000000000
--- a/meta/packages/oh/usbinit.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Initscript to manage gadget Ethernet"
-LICENSE = "GPL"
-PRIORITY = "optional"
-PR = "r1"
-
-SRC_URI = "file://usb-gether"
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}/etc
- install -d ${D}/etc/init.d
- install usb-gether ${D}/etc/init.d
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "usb-gether"
-INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/meta/packages/oh/usbinit/usb-gether b/meta/packages/oh/usbinit/usb-gether
deleted file mode 100755
index e80a0bb30..000000000
--- a/meta/packages/oh/usbinit/usb-gether
+++ /dev/null
@@ -1,23 +0,0 @@
-#! /bin/sh
-#
-# usb-ether Start up the gadget usb ethernet interface.
-#
-
-case "$1" in
- start|"")
- test "$VERBOSE" != no && echo "Initializing g_ether gadget..."
- modprobe g_ether
- ifup usb0
- ;;
- stop)
- test "$VERBOSE" != no && echo "Disabling g_ether..."
- ifdown usb0
- rmmod g_ether
- ;;
- *)
- echo "Usage: usb-ether {start|stop}" >&2
- exit 1
- ;;
-esac
-
-exit 0