summaryrefslogtreecommitdiff
path: root/meta/packages/opensync
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-06-18 08:35:37 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-06-18 08:35:37 +0000
commit6c0e524a7c7b4bfd3e809b1221e33b20a11a3221 (patch)
tree72c905936dada5342c96cddb55c083315da8fcca /meta/packages/opensync
parentda3040f29760899db17b4ec1cd0fd238897229e0 (diff)
downloadopenembedded-core-6c0e524a7c7b4bfd3e809b1221e33b20a11a3221.tar.gz
openembedded-core-6c0e524a7c7b4bfd3e809b1221e33b20a11a3221.tar.bz2
openembedded-core-6c0e524a7c7b4bfd3e809b1221e33b20a11a3221.tar.xz
openembedded-core-6c0e524a7c7b4bfd3e809b1221e33b20a11a3221.zip
libsyncml: added 0.4.6
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4689 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/opensync')
-rw-r--r--meta/packages/opensync/libsyncml/build-in-src.patch21
-rw-r--r--meta/packages/opensync/libsyncml_0.4.6.bb18
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/opensync/libsyncml/build-in-src.patch b/meta/packages/opensync/libsyncml/build-in-src.patch
new file mode 100644
index 000000000..20dd06f36
--- /dev/null
+++ b/meta/packages/opensync/libsyncml/build-in-src.patch
@@ -0,0 +1,21 @@
+---
+ CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+--- libsyncml-0.4.6.orig/CMakeLists.txt
++++ libsyncml-0.4.6/CMakeLists.txt
+@@ -39,14 +39,10 @@ CHECK_INCLUDE_FILES( unistd.h HAVE_UNIST
+
+ CHECK_TYPE_SIZE( uint16_t UINT16_T )
+ CHECK_TYPE_SIZE( uint32_t UINT32_T )
+ CHECK_TYPE_SIZE( uint8_t UINT8_T )
+
+-# ensure out od source build
+-INCLUDE( MacroEnsureOutOfSourceBuild )
+-MACRO_ENSURE_OUT_OF_SOURCE_BUILD("${CMAKE_PROJECT_NAME} doesn't allow to build within the source directory. Please, create a seperate build directory and run 'cmake ${PROJECT_SOURCE_DIR} [options]'!")
+-
+ # find requirements
+ SET ( OPENOBEX_MIN_VERSION "1.1" )
+ SET ( LIBSOUP2_MIN_VERSION "2.2.91" )
+ #SET ( LIBWBXML2_MIN_VERSION "0.9.0" )
+ #SET ( BLUEZ_MIN_VERSION "3.19" )
diff --git a/meta/packages/opensync/libsyncml_0.4.6.bb b/meta/packages/opensync/libsyncml_0.4.6.bb
new file mode 100644
index 000000000..297a1ca45
--- /dev/null
+++ b/meta/packages/opensync/libsyncml_0.4.6.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol."
+HOMEPAGE = "http://libsyncml.opensync.org/"
+LICENSE = "LGPL"
+DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez-libs openobex"
+
+SRC_URI = "http://libsyncml.opensync.org/download/releases/${PV}/libsyncml-${PV}.tar.bz2 \
+ file://build-in-src.patch;patch=1"
+
+inherit cmake pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"