summaryrefslogtreecommitdiff
path: root/meta/packages/opkg-utils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-27 16:12:57 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-27 16:12:57 +0100
commitc5983de05495c911e78da8ce0edee4055f85e3be (patch)
treecf3be7742c87b1e51f03633f29a621303b64e1a2 /meta/packages/opkg-utils
parent670a7ee294ed5a9e7cc40a4409825eb5035bb5a5 (diff)
downloadopenembedded-core-c5983de05495c911e78da8ce0edee4055f85e3be.tar.gz
openembedded-core-c5983de05495c911e78da8ce0edee4055f85e3be.tar.bz2
openembedded-core-c5983de05495c911e78da8ce0edee4055f85e3be.tar.xz
openembedded-core-c5983de05495c911e78da8ce0edee4055f85e3be.zip
opkg-utils: Update changing .ipk avoidence patch
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/opkg-utils')
-rw-r--r--meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch22
-rw-r--r--meta/packages/opkg-utils/opkg-utils_svn.bb2
2 files changed, 19 insertions, 5 deletions
diff --git a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
index bafc2f6a1..e4a548156 100644
--- a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
+++ b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
@@ -1,7 +1,14 @@
+If we're building an image and some package rebuilds while this is happening
+some package can be removed/added to the ipk deploy directory. The image will
+not depend on this package so we can safely ignore these cases rather than
+error out.
+
+RP - 26/8/09
+
Index: opkg-utils/opkg-make-index
===================================================================
--- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100
-+++ opkg-utils/opkg-make-index 2009-08-26 20:49:52.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-27 16:11:22.000000000 +0100
@@ -96,6 +96,7 @@
files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
files.sort()
@@ -10,17 +17,20 @@ Index: opkg-utils/opkg-make-index
basename = os.path.basename(filename)
pkg = None
fnameStat = os.stat(filename)
-@@ -130,6 +131,9 @@
+@@ -130,6 +131,12 @@
to_morgue(basename)
if opt_s:
print filename
+ except OSError:
+ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
+ continue
++ except IOError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
++ continue
pkgsStampsFile = open(stamplist_filename, "w")
for f in pkgsStamps.keys():
-@@ -148,6 +152,7 @@
+@@ -148,6 +155,7 @@
names = packages.packages.keys()
names.sort()
for name in names:
@@ -28,13 +38,17 @@ Index: opkg-utils/opkg-make-index
pkg = packages.packages[name]
if locales_dir and pkg.depends:
depends = string.split(pkg.depends, ',')
-@@ -165,6 +170,9 @@
+@@ -165,6 +173,13 @@
if (verbose):
sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
print pkg
+ except OSError:
+ sys.stderr.write("Package %s disappeared on us!\n" % (name))
+ continue
++ except IOError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
++
if packages_filename:
sys.stdout.close()
sys.stdout = old_stdout
diff --git a/meta/packages/opkg-utils/opkg-utils_svn.bb b/meta/packages/opkg-utils/opkg-utils_svn.bb
index a14150571..b06ea6a68 100644
--- a/meta/packages/opkg-utils/opkg-utils_svn.bb
+++ b/meta/packages/opkg-utils/opkg-utils_svn.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
RDEPENDS = "python"
RDEPENDS_virtclass-native = ""
-PR = "r5"
+PR = "r6"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch;patch=1"