summaryrefslogtreecommitdiff
path: root/meta/packages/oprofile
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-27 16:30:56 +0000
committerRoss Burton <ross@openedhand.com>2007-11-27 16:30:56 +0000
commitfc5d8af7a71876283b16f1a9a0fb701aa7c1db74 (patch)
tree942b2aa45bbbc1cd4804167dfd86ce7683b5a01d /meta/packages/oprofile
parent261c8d8c775f44b6935a5b36ee00a084910afae7 (diff)
downloadopenembedded-core-fc5d8af7a71876283b16f1a9a0fb701aa7c1db74.tar.gz
openembedded-core-fc5d8af7a71876283b16f1a9a0fb701aa7c1db74.tar.bz2
openembedded-core-fc5d8af7a71876283b16f1a9a0fb701aa7c1db74.tar.xz
openembedded-core-fc5d8af7a71876283b16f1a9a0fb701aa7c1db74.zip
oprofile: fix arithmetic ops on dash
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3259 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oprofile')
-rw-r--r--meta/packages/oprofile/oprofile/fix-arith.patch52
-rw-r--r--meta/packages/oprofile/oprofile_0.9.3.bb3
2 files changed, 54 insertions, 1 deletions
diff --git a/meta/packages/oprofile/oprofile/fix-arith.patch b/meta/packages/oprofile/oprofile/fix-arith.patch
new file mode 100644
index 000000000..5c55f4b34
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/fix-arith.patch
@@ -0,0 +1,52 @@
+Index: utils/opcontrol
+===================================================================
+RCS file: /cvsroot/oprofile/oprofile/utils/opcontrol,v
+retrieving revision 1.148
+diff -u -r1.148 opcontrol
+--- utils/opcontrol 8 Nov 2007 09:24:30 -0000 1.148
++++ utils/opcontrol 27 Nov 2007 17:02:20 -0000
+@@ -395,7 +395,7 @@
+ echo "SESSION_DIR=$SESSION_DIR" >>$SETUP_FILE
+
+ if test "$NR_CHOSEN" != "0"; then
+- for f in `seq 0 $((NR_CHOSEN - 1))`; do
++ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+ get_event $f
+ echo "CHOSEN_EVENTS_${f}=$GOTEVENT" >>$SETUP_FILE
+ done
+@@ -590,7 +590,7 @@
+ OPHELP_ARGS=
+
+ if test "$NR_CHOSEN" != 0; then
+- for f in `seq 0 $((NR_CHOSEN - 1))`; do
++ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+ get_event $f
+ if test "$GOTEVENT" != ""; then
+ OPHELP_ARGS="$OPHELP_ARGS $GOTEVENT"
+@@ -612,7 +612,7 @@
+ return
+ fi
+
+- for f in `seq 0 $((NR_CHOSEN - 1))`; do
++ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+ get_event $f
+ if test "$GOTEVENT" != ""; then
+ EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
+@@ -1226,7 +1226,7 @@
+ verify_counters
+
+ OPROFILED_EVENTS=
+- for f in `seq 0 $((NR_CHOSEN - 1))`; do
++ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+ get_event $f
+ if test "$GOTEVENT" != ""; then
+ EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
+@@ -1383,7 +1383,7 @@
+ fi
+
+ if test "$NR_CHOSEN" != "0"; then
+- for f in `seq 0 $((NR_CHOSEN - 1))`; do
++ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+ get_event $f
+ echo "Event $f: $GOTEVENT"
+ done
diff --git a/meta/packages/oprofile/oprofile_0.9.3.bb b/meta/packages/oprofile/oprofile_0.9.3.bb
index c4ea585c8..c4194ab2e 100644
--- a/meta/packages/oprofile/oprofile_0.9.3.bb
+++ b/meta/packages/oprofile/oprofile_0.9.3.bb
@@ -4,13 +4,14 @@ of profiling all running code at low overhead."
LICENSE = "GPL"
DEPENDS = "popt binutils"
RDEPENDS = "binutils-symlinks"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
file://armv6_fix.patch;patch=1 \
file://oparchive_fix.patch;patch=1 \
file://root_option.patch;patch=1 \
file://opstart.patch;patch=1 \
+ file://fix-arith.patch;patch=1;pnum=0 \
file://acinclude.m4"
S = "${WORKDIR}/oprofile-${PV}"