summaryrefslogtreecommitdiff
path: root/meta/packages/packagekit
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2008-11-04 22:11:58 +0000
committerJoshua Lock <josh@linux.intel.com>2008-11-04 22:11:58 +0000
commit76bf51b126a8e8a4968ff004fbbe2be65620dfe6 (patch)
treed9f846a0db27fdd5e941fa78118da5b4575e3bd4 /meta/packages/packagekit
parentd422ac1c2503960ab05f390d26c911d83a7d4aa9 (diff)
downloadopenembedded-core-76bf51b126a8e8a4968ff004fbbe2be65620dfe6.tar.gz
openembedded-core-76bf51b126a8e8a4968ff004fbbe2be65620dfe6.tar.bz2
openembedded-core-76bf51b126a8e8a4968ff004fbbe2be65620dfe6.tar.xz
openembedded-core-76bf51b126a8e8a4968ff004fbbe2be65620dfe6.zip
packagekit: fix typo in folder name
Diffstat (limited to 'meta/packages/packagekit')
-rw-r--r--meta/packages/packagekit/files/no_validate.patch21
-rw-r--r--meta/packages/packagekit/packagekit_0.3.8.bb12
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/packagekit/files/no_validate.patch b/meta/packages/packagekit/files/no_validate.patch
new file mode 100644
index 000000000..f987b567d
--- /dev/null
+++ b/meta/packages/packagekit/files/no_validate.patch
@@ -0,0 +1,21 @@
+Index: PackageKit-0.3.8/configure.ac
+===================================================================
+--- PackageKit-0.3.8.orig/configure.ac 2008-11-04 21:37:17.000000000 +0000
++++ PackageKit-0.3.8/configure.ac 2008-11-04 21:37:57.000000000 +0000
+@@ -451,11 +451,11 @@
+ polkit-grant >= $POLKIT_GRANT_REQUIRED)
+ AC_SUBST(POLKIT_CFLAGS)
+ AC_SUBST(POLKIT_LIBS)
+- AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
+- [polkit-policy-file-validate], [polkit-policy-file-validate])
+- if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
+- AC_MSG_ERROR([polkit-policy-file-validate not found])
+- fi
++ #AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
++ # [polkit-policy-file-validate], [polkit-policy-file-validate])
++ #if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
++ # AC_MSG_ERROR([polkit-policy-file-validate not found])
++ #fi
+ AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
+ elif test x$with_security_framework = xdummy; then
+ AC_DEFINE(USE_SECURITY_DUMMY, 1, [if we should use a dummy security framework])
diff --git a/meta/packages/packagekit/packagekit_0.3.8.bb b/meta/packages/packagekit/packagekit_0.3.8.bb
new file mode 100644
index 000000000..6b44aeac7
--- /dev/null
+++ b/meta/packages/packagekit/packagekit_0.3.8.bb
@@ -0,0 +1,12 @@
+HOMEPAGE = "http://www.packagekit.org/"
+PR = "r6"
+
+SRC_URI = "http://www.packagekit.org/releases/PackageKit-0.3.8.tar.gz \
+ file://no_validate.patch;patch=1 "
+
+DEPENDS = "python polkit pam"
+EXTRA_OECONF = "--disable-qt --disable-tests --enable-yum --with-default-backend=yum --disable-local --with-security-framework=polkit --disable-gstreamer-plugin"
+
+S = "${WORKDIR}/PackageKit-${PV}"
+
+inherit autotools pkgconfig