summaryrefslogtreecommitdiff
path: root/meta/packages/pax-utils
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-01-22 17:02:26 +0000
committerRoss Burton <ross@openedhand.com>2007-01-22 17:02:26 +0000
commitae28b7fed99ab48cc3b05cd57ee38faaea50fb5c (patch)
tree8889206f5f36b6baed8baaeeb74095e0e4e213b2 /meta/packages/pax-utils
parent8d774c0a31a1599c1929d180772f25a0534c7649 (diff)
downloadopenembedded-core-ae28b7fed99ab48cc3b05cd57ee38faaea50fb5c.tar.gz
openembedded-core-ae28b7fed99ab48cc3b05cd57ee38faaea50fb5c.tar.bz2
openembedded-core-ae28b7fed99ab48cc3b05cd57ee38faaea50fb5c.tar.xz
openembedded-core-ae28b7fed99ab48cc3b05cd57ee38faaea50fb5c.zip
Add pax-utils for insane.bbclass
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1194 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pax-utils')
-rw-r--r--meta/packages/pax-utils/pax-utils-native_0.1.13.bb7
-rw-r--r--meta/packages/pax-utils/pax-utils_0.1.13.bb17
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/pax-utils/pax-utils-native_0.1.13.bb b/meta/packages/pax-utils/pax-utils-native_0.1.13.bb
new file mode 100644
index 000000000..d586dcb29
--- /dev/null
+++ b/meta/packages/pax-utils/pax-utils-native_0.1.13.bb
@@ -0,0 +1,7 @@
+inherit native
+
+require pax-utils_${PV}.bb
+
+do_stage() {
+ oe_runmake PREFIX=${STAGING_DIR}/${HOST_SYS} install
+}
diff --git a/meta/packages/pax-utils/pax-utils_0.1.13.bb b/meta/packages/pax-utils/pax-utils_0.1.13.bb
new file mode 100644
index 000000000..6fc685014
--- /dev/null
+++ b/meta/packages/pax-utils/pax-utils_0.1.13.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Various ELF utilities"
+HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE = "GPLv2"
+
+SRC_URI = "${GENTOO_MIRROR}/pax-utils-${PV}.tar.bz2;md5sum=5f09df47a16e83462384b44b75310539"
+S = "${WORKDIR}/pax-utils-${PV}"
+
+CPPFLAGS += "-D_GNU_SOURCE "
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+