summaryrefslogtreecommitdiff
path: root/meta/packages/pciutils/pciutils_2.2.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
commitf8ca66bdb7fff028d9826b79afb9265f235735f2 (patch)
treebbf5e45cd4b4ce8a3ac7754891ae69e7fcd41379 /meta/packages/pciutils/pciutils_2.2.4.bb
parentba9dd5228c290c96c622fb82964e49ce2511a1e9 (diff)
downloadopenembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.gz
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.bz2
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.xz
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.zip
pciutils: added 2.2.4 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2054 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pciutils/pciutils_2.2.4.bb')
-rw-r--r--meta/packages/pciutils/pciutils_2.2.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/pciutils/pciutils_2.2.4.bb b/meta/packages/pciutils/pciutils_2.2.4.bb
new file mode 100644
index 000000000..0cd335eb3
--- /dev/null
+++ b/meta/packages/pciutils/pciutils_2.2.4.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
+to PCI bus configuration space and several utilities based on this library.'
+DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
+SECTION = "console/utils"
+HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://configure-uclibc.patch;patch=1 \
+ file://pcimodules-pciutils.diff;patch=1"
+
+PARALLEL_MAKE = ""
+
+PR="r1"
+
+do_configure () {
+ (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
+}
+
+export PREFIX = "${D}${prefix}"
+export SBINDIR = "${D}${sbindir}"
+export SHAREDIR = "${D}${datadir}"
+export MANDIR = "${D}${mandir}"
+
+LDFLAGS += "-lz"
+
+do_install () {
+ oe_runmake install
+}
+do_install_append () {
+ install -d ${D}/${prefix}/share
+ install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+}
+
+PACKAGES =+ "pciutils-ids"
+FILES_pciutils-ids="${prefix}/share/pci.ids"