summaryrefslogtreecommitdiff
path: root/meta/packages/perl/perl.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-27 21:04:11 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-27 21:04:11 +0000
commit80785a10721e523029c27f264fca5a892cf68e36 (patch)
treed33b51538db742a5d6f8df6b184b5531e8bf68ce /meta/packages/perl/perl.inc
parentbd4fd028a799e804d803eac14ccb9e164ecc4938 (diff)
downloadopenembedded-core-80785a10721e523029c27f264fca5a892cf68e36.tar.gz
openembedded-core-80785a10721e523029c27f264fca5a892cf68e36.tar.bz2
openembedded-core-80785a10721e523029c27f264fca5a892cf68e36.tar.xz
openembedded-core-80785a10721e523029c27f264fca5a892cf68e36.zip
perl: 5.8.7 -> 5.8.8 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1785 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl/perl.inc')
-rw-r--r--meta/packages/perl/perl.inc34
1 files changed, 7 insertions, 27 deletions
diff --git a/meta/packages/perl/perl.inc b/meta/packages/perl/perl.inc
index 4f42d78de..9e20ae63e 100644
--- a/meta/packages/perl/perl.inc
+++ b/meta/packages/perl/perl.inc
@@ -9,43 +9,23 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://Makefile.patch;patch=1 \
file://config.sh-arm-linux.patch;patch=1 \
file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \
- file://uclibc.patch;patch=1 \
- file://Makefile.SH.patch \
- file://config.sh-mipsel-linux \
- file://config.sh-i686-linux"
+ file://Makefile.SH.patch"
HOSTPERL="${STAGING_BINDIR_NATIVE}/perl${PV}"
-do_configure() {
- ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
- cp ${HOSTPERL} hostperl
- cd Cross
- rm -f Makefile.SH.patch
- cp ${WORKDIR}/Makefile.SH.patch .
- cp ${WORKDIR}/config.sh-mipsel-linux .
- cp ${WORKDIR}/config.sh-i686-linux .
- cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
- for i in config.sh-*-linux; do
- a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
- newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
- cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
- s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
- done
- sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
- rm -f config
- echo "ARCH = ${TARGET_ARCH}" > config
- echo "OS = ${TARGET_OS}" >> config
- oe_runmake patch
-}
-
do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
cd Cross
# You must use gcc to link on sh
OPTIONS=""
if test ${TARGET_ARCH} = "sh3" -o ${TARGET_ARCH} = "sh4"; then
- OPTIONS="LD=${TARGET_ARCH}-${TARGET_OS}-gcc"
+ OPTIONS="LD=${TARGET_SYS}-gcc"
fi
+ # You must use gcc to link on powerpc also
+ if test ${TARGET_ARCH} = "powerpc" ; then
+ OPTIONS="LD=${TARGET_SYS}-gcc"
+ fi
+
oe_runmake perl $OPTIONS
}