summaryrefslogtreecommitdiff
path: root/meta/packages/perl/perl_5.8.7.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-08-18 22:19:53 +0000
committerRichard Purdie <richard@openedhand.com>2006-08-18 22:19:53 +0000
commit017f9dbb6b05db364e9e930f5e30b02f2053e00b (patch)
tree18c4c3fce84a64e7b1942bab7756d1d70f24a575 /meta/packages/perl/perl_5.8.7.bb
parent467265320c287ab20a302de1251afbc13b7d3ada (diff)
downloadopenembedded-core-017f9dbb6b05db364e9e930f5e30b02f2053e00b.tar.gz
openembedded-core-017f9dbb6b05db364e9e930f5e30b02f2053e00b.tar.bz2
openembedded-core-017f9dbb6b05db364e9e930f5e30b02f2053e00b.tar.xz
openembedded-core-017f9dbb6b05db364e9e930f5e30b02f2053e00b.zip
perl/perl-native: Sync with OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@618 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl/perl_5.8.7.bb')
-rw-r--r--meta/packages/perl/perl_5.8.7.bb31
1 files changed, 25 insertions, 6 deletions
diff --git a/meta/packages/perl/perl_5.8.7.bb b/meta/packages/perl/perl_5.8.7.bb
index 456cc95c8..b3cfd1a3b 100644
--- a/meta/packages/perl/perl_5.8.7.bb
+++ b/meta/packages/perl/perl_5.8.7.bb
@@ -1,12 +1,18 @@
MAINTAINER="David Karlstrom <daka@thg.se>"
-include perl.inc
+require perl.inc
SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-arm-linux \
- file://config.sh-i386-linux"
+ file://config.sh-i386-linux \
+ file://config.sh-i486-linux \
+ file://config.sh-i586-linux \
+ file://config.sh-sh3-linux \
+ file://config.sh-sh4-linux"
-PR = "r15"
+PARALLEL_MAKE = ""
+
+PR = "r17"
do_configure() {
ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl
@@ -15,9 +21,13 @@ do_configure() {
rm Makefile.SH.patch
cp ${WORKDIR}/Makefile.SH.patch .
cp ${WORKDIR}/config.sh-mipsel-linux .
- cp ${WORKDIR}/config.sh-i686-linux .
cp ${WORKDIR}/config.sh-i386-linux .
+ cp ${WORKDIR}/config.sh-i486-linux .
+ cp ${WORKDIR}/config.sh-i586-linux .
+ cp ${WORKDIR}/config.sh-i686-linux .
cp ${WORKDIR}/config.sh-armeb-linux .
+ cp ${WORKDIR}/config.sh-sh3-linux .
+ cp ${WORKDIR}/config.sh-sh4-linux .
#perl insists on an extra config.sh for arm EABI
cp config.sh-arm-linux config.sh-arm-linux-gnueabi
# nslu2 LE uclibc builds do not work with the default config.sh
@@ -33,6 +43,13 @@ do_configure() {
s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
done
sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
+ sed -i -e "s%/usr/include/%${STAGING_INCDIR}/%g" config.sh-${TARGET_ARCH}-${TARGET_OS}
+
+ #These are strewn all over the source tree
+ for foo in `grep -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+ echo Fixing: $foo
+ sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
+ done
rm -f config
echo "ARCH = ${TARGET_ARCH}" > config
echo "OS = ${TARGET_OS}" >> config
@@ -40,7 +57,9 @@ do_configure() {
}
do_install_append() {
- ln -s libperl.so.${PV} ${D}/${libdir}/libperl.so.5
+ # Make sure the shared library is configured before trying to symlink it
+ grep -q "useshrplib='false'" ${S}/config.sh ||
+ ln -s libperl.so.${PV} ${D}/${libdir}/libperl.so.5
sed -i -e "s,${D},,g" ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-${TARGET_OS}/Config_heavy.pl
}
@@ -52,7 +71,7 @@ RRECOMMENDS_perl-modules = "${PACKAGES}"
RPROVIDES_perl-lib = "perl-lib"
-include perl-rdepends_${PV}.inc
+require perl-rdepends_${PV}.inc
# To create/update the perl-rdepends_${PV}.inc use this piece of ugly script (modified for your arch/paths etc):
# daka@DaKa2:/home/slug/slugos/tmp/work/perl-5.8.7-r14/install$ egrep -r "use|require" * | grep ";$" | egrep ".pm:use |.pm:require " | grep -v v5.6.0 | grep -v 5.00 | grep -v \$module | sed -e "s, \+, ,g" | cut -f1,2 -d" " | sed -e "s,;, ,g" | sed -e "s,(), ,g" | sed -e "s,::,-,g" | sort | uniq | tr [:upper:] [:lower:] | sed -e "s,/[^ ]\+ , += \"perl-module-,g" | sed -e "s, \?$, \",g" | sed -e "s,_,-,g" | sed -e "s,^,RDEPENDS_,g" | sed -e "s,armeb-linux,\$\{TARGET_ARCH\}-\$\{TARGET_OS\},g" | egrep -v "perl-module-5|perl-module-tk|perl-module-mac-internetconfig|perl-module-ndbm-file|perl-module-html-treebuilder|perl-module-lwp-simple|perl-module-vms-filespec|perl-module-fcgi|perl-module-vms-stdio|perl-module-mac-buildtools" > /home/slug/openembedded/packages/perl/perl-rdepends_5.8.7.inc