summaryrefslogtreecommitdiff
path: root/meta/packages/pointercal/pointercal_0.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-17 14:27:18 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-17 14:27:18 +0000
commit5c3459c7e3c1461c5563ea18f87158dc7692b9d5 (patch)
tree890c1ed27cda9a3a3c099f4f7f359216f34ee63d /meta/packages/pointercal/pointercal_0.0.bb
parente2567c42dd3eb98dcfdaa64160cdbe35152e7b9b (diff)
downloadopenembedded-core-5c3459c7e3c1461c5563ea18f87158dc7692b9d5.tar.gz
openembedded-core-5c3459c7e3c1461c5563ea18f87158dc7692b9d5.tar.bz2
openembedded-core-5c3459c7e3c1461c5563ea18f87158dc7692b9d5.tar.xz
openembedded-core-5c3459c7e3c1461c5563ea18f87158dc7692b9d5.zip
pointercal: Always create a package but empty on devices without a default
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1751 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pointercal/pointercal_0.0.bb')
-rw-r--r--meta/packages/pointercal/pointercal_0.0.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/packages/pointercal/pointercal_0.0.bb b/meta/packages/pointercal/pointercal_0.0.bb
index 36bcca85b..6cf50241a 100644
--- a/meta/packages/pointercal/pointercal_0.0.bb
+++ b/meta/packages/pointercal/pointercal_0.0.bb
@@ -1,14 +1,17 @@
DESCRIPTION = "Touchscreen calibration data"
SECTION = "base"
-
-COMPATIBLE_MACHINE = "(spitz|c7x0|nokia800|akita)"
+PR = "r1"
SRC_URI = "file://pointercal"
S = "${WORKDIR}"
+ALLOW_EMPTY_${PN} = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_install() {
- install -d ${D}${sysconfdir}/
- install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ fi
}