summaryrefslogtreecommitdiff
path: root/meta/packages/puzzles/oh-puzzles_svn.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-02 16:00:08 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-02 16:00:08 +0000
commit505ff5236411b28d904bdc5a83b94be609097c45 (patch)
treeb1ddb6872d6645512f496ef37f791a0db720d0c2 /meta/packages/puzzles/oh-puzzles_svn.bb
parent7371e6323c3fb6b0545712e3cf84606644073e77 (diff)
downloadopenembedded-core-505ff5236411b28d904bdc5a83b94be609097c45.tar.gz
openembedded-core-505ff5236411b28d904bdc5a83b94be609097c45.tar.bz2
openembedded-core-505ff5236411b28d904bdc5a83b94be609097c45.tar.xz
openembedded-core-505ff5236411b28d904bdc5a83b94be609097c45.zip
oh-puzzles: added SVN version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1420 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/puzzles/oh-puzzles_svn.bb')
-rw-r--r--meta/packages/puzzles/oh-puzzles_svn.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/packages/puzzles/oh-puzzles_svn.bb b/meta/packages/puzzles/oh-puzzles_svn.bb
new file mode 100644
index 000000000..7a9a52b61
--- /dev/null
+++ b/meta/packages/puzzles/oh-puzzles_svn.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Portable Puzzle Collection"
+LICENSE = "MIT"
+SECTION = "x11"
+DEPENDS = "gtk+"
+PV = "0.1+svn${SRCDATE}"
+
+inherit autotools pkgconfig
+
+SRC_URI = "svn://svn.o-hand.com/repos/;module=oh-puzzles;proto=http \
+ file://game.png"
+
+S = "${WORKDIR}/${PN}"
+
+do_install_append () {
+ mv ${D}${bindir} ${D}/usr/games
+
+ install -d ${D}/${datadir}/applications/
+ install -d ${D}/${datadir}/pixmaps/
+
+ install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps/
+
+ cd ${D}/${prefix}/games
+ for prog in *; do
+ if [ -x $prog ]; then
+ echo "making ${D}/${datadir}/applications/$prog.desktop"
+ cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
+[Desktop Entry]
+Encoding=UTF-8
+Name=$prog
+Exec=${prefix}/games/$prog
+Icon=game.png
+Terminal=false
+Type=Application
+Categories=Game
+StartupNotify=true
+SingleInstance=true
+STOP
+ fi
+ done
+}
+
+FILES_${PN} += "/usr/games/*"
+FILES_${PN}-dbg += "/usr/games/.debug/*"