summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-12-03 12:08:52 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-12-03 12:08:52 +0000
commitba1c4fa94426f8e46bf0e9ab1d225039bdb78158 (patch)
tree1a279f092f44d36c8218ee2430005b6a772a83d3 /meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch
parent3b5336f7cf1c01c23e2fd81b54fbf89558fc2cd4 (diff)
downloadopenembedded-core-ba1c4fa94426f8e46bf0e9ab1d225039bdb78158.tar.gz
openembedded-core-ba1c4fa94426f8e46bf0e9ab1d225039bdb78158.tar.bz2
openembedded-core-ba1c4fa94426f8e46bf0e9ab1d225039bdb78158.tar.xz
openembedded-core-ba1c4fa94426f8e46bf0e9ab1d225039bdb78158.zip
python: Update 2.5 -> 2.6 (from OE.dev)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch')
-rw-r--r--meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch b/meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch
new file mode 100644
index 000000000..a1a385a07
--- /dev/null
+++ b/meta/packages/python/python-2.6.1/03-fix-tkinter-detection.patch
@@ -0,0 +1,40 @@
+# We need to supply STAGING_INCDIR here, otherwise the Tk headers
+# will not be found.
+# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille.de>
+
+Index: Python-2.6.1/setup.py
+===================================================================
+--- Python-2.6.1.orig/setup.py
++++ Python-2.6.1/setup.py
+@@ -1543,7 +1543,7 @@ class PyBuildExt(build_ext):
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1562,22 +1562,6 @@ class PyBuildExt(build_ext):
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)