summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-native-2.5.1
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-25 20:33:55 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-25 20:33:55 +0000
commit16e6877c4ce53fd3be88dd77263a03e7d88c3163 (patch)
tree831004ca391e04c8deaace28b15cb602c0848c77 /meta/packages/python/python-native-2.5.1
parent07eeb6a8b6d671db7566f839ab22a26b6f118077 (diff)
downloadopenembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.gz
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.bz2
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.xz
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.zip
python: Promote from meta-extras to meta
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5092 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/python/python-native-2.5.1')
-rw-r--r--meta/packages/python/python-native-2.5.1/bindir-libdir.patch18
-rw-r--r--meta/packages/python/python-native-2.5.1/catchup-with-swig.patch13
-rw-r--r--meta/packages/python/python-native-2.5.1/cross-distutils.patch36
-rw-r--r--meta/packages/python/python-native-2.5.1/default-is-optimized.patch13
-rw-r--r--meta/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch16
-rw-r--r--meta/packages/python/python-native-2.5.1/fix-staging.patch38
6 files changed, 134 insertions, 0 deletions
diff --git a/meta/packages/python/python-native-2.5.1/bindir-libdir.patch b/meta/packages/python/python-native-2.5.1/bindir-libdir.patch
new file mode 100644
index 000000000..999bddc44
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/bindir-libdir.patch
@@ -0,0 +1,18 @@
+
+#
+# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200
++++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100
+@@ -78,8 +78,8 @@
+ exec_prefix= @exec_prefix@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/meta/packages/python/python-native-2.5.1/catchup-with-swig.patch b/meta/packages/python/python-native-2.5.1/catchup-with-swig.patch
new file mode 100644
index 000000000..f049b759f
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/catchup-with-swig.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Lib/distutils/command/build_ext.py
+===================================================================
+--- Python-2.5.1.orig/Lib/distutils/command/build_ext.py
++++ Python-2.5.1/Lib/distutils/command/build_ext.py
+@@ -513,7 +513,7 @@ class build_ext (Command):
+ target_lang=language)
+
+
+- def swig_sources (self, sources, extension):
++ def swig_sources (self, sources, extension=None):
+
+ """Walk the list of source files in 'sources', looking for SWIG
+ interface (.i) files. Run SWIG on all that are found, and
diff --git a/meta/packages/python/python-native-2.5.1/cross-distutils.patch b/meta/packages/python/python-native-2.5.1/cross-distutils.patch
new file mode 100644
index 000000000..3356c1abb
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/cross-distutils.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100
++++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100
+@@ -19,8 +19,8 @@
+ from errors import DistutilsPlatformError
+
+ # These are needed in a couple of spots, so just compute them once.
+-PREFIX = os.path.normpath(sys.prefix)
+-EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
++PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
++EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+ # python_build: (Boolean) if true, we're either building Python or
+ # building an extension with an un-installed Python, so we use
+@@ -192,7 +192,7 @@
+ else:
+ # The name of the config.h file changed in 2.2
+ config_h = 'pyconfig.h'
+- return os.path.join(inc_dir, config_h)
++ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def get_makefile_filename():
+@@ -200,7 +200,7 @@
+ if python_build:
+ return os.path.join(os.path.dirname(sys.executable), "Makefile")
+ lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
+- return os.path.join(lib_dir, "config", "Makefile")
++ return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def parse_config_h(fp, g=None):
diff --git a/meta/packages/python/python-native-2.5.1/default-is-optimized.patch b/meta/packages/python/python-native-2.5.1/default-is-optimized.patch
new file mode 100644
index 000000000..6beeb6e02
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/default-is-optimized.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Python/compile.c
+===================================================================
+--- Python-2.5.1.orig/Python/compile.c
++++ Python-2.5.1/Python/compile.c
+@@ -30,7 +30,7 @@
+ #include "symtable.h"
+ #include "opcode.h"
+
+-int Py_OptimizeFlag = 0;
++int Py_OptimizeFlag = 1;
+
+ /*
+ ISSUES:
diff --git a/meta/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch b/meta/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
new file mode 100644
index 000000000..54109afd6
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line
++++ Python-2.4/Lib/distutils/command/build_scripts.py
+@@ -87,7 +87,7 @@
+ continue
+
+ match = first_line_re.match(first_line)
+- if match:
++ if False: #match:
+ adjust = 1
+ post_interp = match.group(1) or ''
+
diff --git a/meta/packages/python/python-native-2.5.1/fix-staging.patch b/meta/packages/python/python-native-2.5.1/fix-staging.patch
new file mode 100644
index 000000000..087c813fd
--- /dev/null
+++ b/meta/packages/python/python-native-2.5.1/fix-staging.patch
@@ -0,0 +1,38 @@
+---
+ Lib/distutils/sysconfig.py | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+--- Python-2.5.1.orig/Lib/distutils/sysconfig.py
++++ Python-2.5.1/Lib/distutils/sysconfig.py
+@@ -52,11 +52,14 @@ def get_python_inc(plat_specific=0, pref
+
+ If 'prefix' is supplied, use it instead of sys.prefix or
+ sys.exec_prefix -- i.e., ignore 'plat_specific'.
+ """
+ if prefix is None:
+- prefix = plat_specific and EXEC_PREFIX or PREFIX
++ if plat_specific:
++ prefix = plat_specific and os.environ['STAGING_INCDIR'].rstrip('include')
++ else:
++ prefix = plat_specific and EXEC_PREFIX or PREFIX
+ if os.name == "posix":
+ if python_build:
+ base = os.path.dirname(os.path.abspath(sys.executable))
+ if plat_specific:
+ inc_dir = base
+@@ -94,11 +97,14 @@ def get_python_lib(plat_specific=0, stan
+
+ If 'prefix' is supplied, use it instead of sys.prefix or
+ sys.exec_prefix -- i.e., ignore 'plat_specific'.
+ """
+ if prefix is None:
+- prefix = plat_specific and EXEC_PREFIX or PREFIX
++ if plat_specific:
++ prefix = plat_specific and os.environ['STAGING_LIBDIR'].rstrip('lib')
++ else:
++ prefix = plat_specific and EXEC_PREFIX or PREFIX
+
+ if os.name == "posix":
+ libpython = os.path.join(prefix,
+ "lib", "python" + get_python_version())
+ if standard_lib: