summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-pygobject
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-10 12:21:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-10 12:21:24 +0100
commit12d6acb013433bf9768cd96559070a131ac5b03c (patch)
treefc82a9cba47671f2914dacd0f008347f61deb7c8 /meta/packages/python/python-pygobject
parentde687629d89740d8f748f8a0b11650e5649c66e4 (diff)
downloadopenembedded-core-12d6acb013433bf9768cd96559070a131ac5b03c.tar.gz
openembedded-core-12d6acb013433bf9768cd96559070a131ac5b03c.tar.bz2
openembedded-core-12d6acb013433bf9768cd96559070a131ac5b03c.tar.xz
openembedded-core-12d6acb013433bf9768cd96559070a131ac5b03c.zip
python-gobject: 2.12.3 -> 2.16.0
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/python/python-pygobject')
-rw-r--r--meta/packages/python/python-pygobject/generate-constants.patch18
-rw-r--r--meta/packages/python/python-pygobject/python-path.patch23
2 files changed, 18 insertions, 23 deletions
diff --git a/meta/packages/python/python-pygobject/generate-constants.patch b/meta/packages/python/python-pygobject/generate-constants.patch
new file mode 100644
index 000000000..57a938062
--- /dev/null
+++ b/meta/packages/python/python-pygobject/generate-constants.patch
@@ -0,0 +1,18 @@
+Index: pygobject-2.14.2/gobject/Makefile.am
+===================================================================
+--- pygobject-2.14.2.orig/gobject/Makefile.am
++++ pygobject-2.14.2/gobject/Makefile.am
+@@ -21,11 +21,11 @@ if PLATFORM_WIN32
+ common_ldflags += -no-undefined
+ endif
+
+-constants.py: generate-constants$(EXEEXT) constants.py.in
++constants.py: constants.py.in
+ rm -f constants.py
+ cp $(srcdir)/constants.py.in constants.py
+ chmod 644 constants.py
+- $(top_builddir)/gobject/generate-constants$(EXEEXT) >> constants.py
++ gobject-generate-constants$(EXEEXT) >> constants.py
+ chmod 444 constants.py
+
+ generate_constants_CFLAGS = $(GLIB_CFLAGS)
diff --git a/meta/packages/python/python-pygobject/python-path.patch b/meta/packages/python/python-pygobject/python-path.patch
deleted file mode 100644
index 2ab7bdce6..000000000
--- a/meta/packages/python/python-pygobject/python-path.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: pygobject-2.12.3/m4/python.m4
-===================================================================
---- pygobject-2.12.3.orig/m4/python.m4 2007-03-02 15:00:20.945635455 +0100
-+++ pygobject-2.12.3/m4/python.m4 2007-03-02 15:00:43.532189734 +0100
-@@ -43,12 +43,18 @@
- [AC_REQUIRE([AM_PATH_PYTHON])
- AC_MSG_CHECKING(for headers required to compile python extensions)
- dnl deduce PYTHON_INCLUDES
-+AC_ARG_WITH(python-includes,
-+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
-+if test x$py_exec_prefix != x; then
-+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-+else
- py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
- py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
- PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
- if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
- fi
-+fi
- AC_SUBST(PYTHON_INCLUDES)
- dnl check if the headers exist:
- save_CPPFLAGS="$CPPFLAGS"