summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-03 15:39:57 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-07 16:10:19 +0100
commitbf59d217a8c6376f90832927ad3254fbbbbf48f3 (patch)
treebc80642371198d9cb8f80b39a2c99369a37e2711 /meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
parentfc81ca7d2d4c2a17967af53f82422892da32fb80 (diff)
downloadopenembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.gz
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.bz2
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.xz
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.zip
qemu: Update to 0.12.4
Renamed the recipe to 0.12.4. Moved the patches directory to qemu-0.12.4 - when it was named qemu-0.12, bitbake silently ignored the patches, and only failed when it came time to apply them. Added a FILESDIR to the git recipe and changed its PV to 0.12.4 so it can use the same patches as the normal recipe for now. Removed the series file - it wasn't needed. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-0.12.4/fix-nogl.patch')
-rw-r--r--meta/packages/qemu/qemu-0.12.4/fix-nogl.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
new file mode 100644
index 000000000..68efab3a1
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
@@ -0,0 +1,68 @@
+Index: qemu/Makefile.target
+===================================================================
+--- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400
++++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400
+@@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft
+ libobj-y += op_helper.o helper.o
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_ARM) += dummygl.o
++libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
+ libobj-$(TARGET_ALPHA) += alpha_palcode.o
+
+Index: qemu/target-arm/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
+Index: qemu/target-mips/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}