summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu-0.12.4/no-strip.patch
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-03 15:39:57 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-07 16:10:19 +0100
commitbf59d217a8c6376f90832927ad3254fbbbbf48f3 (patch)
treebc80642371198d9cb8f80b39a2c99369a37e2711 /meta/packages/qemu/qemu-0.12.4/no-strip.patch
parentfc81ca7d2d4c2a17967af53f82422892da32fb80 (diff)
downloadopenembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.gz
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.bz2
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.tar.xz
openembedded-core-bf59d217a8c6376f90832927ad3254fbbbbf48f3.zip
qemu: Update to 0.12.4
Renamed the recipe to 0.12.4. Moved the patches directory to qemu-0.12.4 - when it was named qemu-0.12, bitbake silently ignored the patches, and only failed when it came time to apply them. Added a FILESDIR to the git recipe and changed its PV to 0.12.4 so it can use the same patches as the normal recipe for now. Removed the series file - it wasn't needed. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-0.12.4/no-strip.patch')
-rw-r--r--meta/packages/qemu/qemu-0.12.4/no-strip.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/no-strip.patch b/meta/packages/qemu/qemu-0.12.4/no-strip.patch
new file mode 100644
index 000000000..8a95a688b
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12.4/no-strip.patch
@@ -0,0 +1,26 @@
+Index: qemu/Makefile
+===================================================================
+--- qemu.orig/Makefile 2010-05-11 17:17:06.416912704 -0400
++++ qemu/Makefile 2010-05-11 17:17:17.051812402 -0400
+@@ -300,7 +300,7 @@ endif
+ install: all $(if $(BUILD_DOCS),install-doc)
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ ifneq ($(BLOBS),)
+ $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
+Index: qemu/Makefile.target
+===================================================================
+--- qemu.orig/Makefile.target 2010-05-11 17:17:12.188784092 -0400
++++ qemu/Makefile.target 2010-05-11 17:17:17.052808122 -0400
+@@ -351,7 +351,7 @@ clean:
+
+ install: all
+ ifneq ($(PROGS),)
+- $(INSTALL) -m 755 $(STRIP_OPT) $(PROGS) "$(DESTDIR)$(bindir)"
++ $(INSTALL) -m 755 $(PROGS) "$(DESTDIR)$(bindir)"
+ endif
+
+ # Include automatically generated dependency files