summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu-0.12/fix-nogl.patch
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-05-28 09:13:03 +0100
committerJoshua Lock <josh@linux.intel.com>2010-05-28 15:31:54 +0100
commit32a85c157002874af88a1cd324e1e466bb1df9b6 (patch)
tree9b146de299cd8a4e262becdaeca88b071bc64b44 /meta/packages/qemu/qemu-0.12/fix-nogl.patch
parent3d6e7e7d0c6aed10a859034486191e0b3b69d786 (diff)
downloadopenembedded-core-32a85c157002874af88a1cd324e1e466bb1df9b6.tar.gz
openembedded-core-32a85c157002874af88a1cd324e1e466bb1df9b6.tar.bz2
openembedded-core-32a85c157002874af88a1cd324e1e466bb1df9b6.tar.xz
openembedded-core-32a85c157002874af88a1cd324e1e466bb1df9b6.zip
qemu: reduce duplication, use an inc file and share common patches
There's no need to carry around two copies of the same patches for qemu-git and qemu-0.12 so drop the qemu-git directory and update the git recipe to use the qemu-0.12 directory for patches. Move common code from the two recipes to an inc file. Signed-off-by: Joshua Lock <josh@linux.intel.com> fweh
Diffstat (limited to 'meta/packages/qemu/qemu-0.12/fix-nogl.patch')
-rw-r--r--meta/packages/qemu/qemu-0.12/fix-nogl.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12/fix-nogl.patch b/meta/packages/qemu/qemu-0.12/fix-nogl.patch
new file mode 100644
index 000000000..68efab3a1
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12/fix-nogl.patch
@@ -0,0 +1,68 @@
+Index: qemu/Makefile.target
+===================================================================
+--- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400
++++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400
+@@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft
+ libobj-y += op_helper.o helper.o
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_ARM) += dummygl.o
++libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
+ libobj-$(TARGET_ALPHA) += alpha_palcode.o
+
+Index: qemu/target-arm/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
+Index: qemu/target-mips/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}