summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu_20071121.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-12-03 23:18:02 +0000
committerRichard Purdie <richard@openedhand.com>2007-12-03 23:18:02 +0000
commit11f9f2412eae749d28c99f8bf36f8aee7deb36b4 (patch)
tree35edbce67c753112dd4aff9b7f93fb60f5ba4394 /meta/packages/qemu/qemu_20071121.bb
parentc3c2ee2f424a0041ad2c27d42853a05e683b401f (diff)
downloadopenembedded-core-11f9f2412eae749d28c99f8bf36f8aee7deb36b4.tar.gz
openembedded-core-11f9f2412eae749d28c99f8bf36f8aee7deb36b4.tar.bz2
openembedded-core-11f9f2412eae749d28c99f8bf36f8aee7deb36b4.tar.xz
openembedded-core-11f9f2412eae749d28c99f8bf36f8aee7deb36b4.zip
qemu: Add 20071121 version, default preference -1 for now
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3303 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu/qemu_20071121.bb')
-rw-r--r--meta/packages/qemu/qemu_20071121.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu_20071121.bb b/meta/packages/qemu/qemu_20071121.bb
new file mode 100644
index 000000000..63100806b
--- /dev/null
+++ b/meta/packages/qemu/qemu_20071121.bb
@@ -0,0 +1,58 @@
+LICENSE = "GPL"
+DEPENDS = "zlib"
+SRCDATE = "20071121"
+PV = "0.9.0+cvs${SRCDATE}"
+
+DEFAULT_PREFERENCE = "-1"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}:${FILE_DIRNAME}/files"
+FILESDIR = "${WORKDIR}"
+
+SRC_URI = "\
+ cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
+ file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
+ file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
+ file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
+ file://06_exit_segfault.patch;patch=1;pnum=0 \
+ file://10_signal_jobs.patch;patch=1;pnum=0 \
+ file://11_signal_sigaction.patch;patch=1;pnum=0 \
+ file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
+ file://31_syscalls.patch;patch=1;pnum=0 \
+ file://32_syscall_sysctl.patch;patch=1;pnum=0 \
+ file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
+ file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
+ file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
+ file://52_ne2000_return.patch;patch=1;pnum=1 \
+ file://61_safe_64bit_int.patch;patch=1;pnum=0 \
+ file://63_sparc_build.patch;patch=1;pnum=0 \
+ file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
+ file://65_kfreebsd.patch;patch=1;pnum=0 \
+ file://66_tls_ld.patch;patch=1;pnum=0 \
+ file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
+ file://qemu-0.9.0-nptl.patch;patch=1 \
+ file://qemu-0.9.0-nptl-update.patch;patch=1 \
+ file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
+ file://workaround_bad_futex_headers.patch;patch=1 \
+ file://fix_segfault.patch;patch=1 \
+ file://disable-error-in-configure.patch;patch=1"
+
+# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
+# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
+# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
+# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
+# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
+# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
+# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
+# file://debian/patches/96-x.patch;patch=1"
+
+S = "${WORKDIR}/qemu"
+
+#EXTRA_OECONF += "--disable-sdl"
+#EXTRA_OECONF += "--target-list=arm-linux-user"
+EXTRA_OECONF += "--disable-gfx-check"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}