summaryrefslogtreecommitdiff
path: root/meta/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-24 11:14:32 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-24 11:14:32 +0100
commit75563817929fa7cf9a5cbd4cb46f43aa16978a7d (patch)
tree4dfa217844db07b205cbf1540ffad05e6b4b63ce /meta/packages/qemu
parent362d3886f52d6d4bae57adf81b7dcbd846217dd1 (diff)
downloadopenembedded-core-75563817929fa7cf9a5cbd4cb46f43aa16978a7d.tar.gz
openembedded-core-75563817929fa7cf9a5cbd4cb46f43aa16978a7d.tar.bz2
openembedded-core-75563817929fa7cf9a5cbd4cb46f43aa16978a7d.tar.xz
openembedded-core-75563817929fa7cf9a5cbd4cb46f43aa16978a7d.zip
qemu: Fix for machines without zlib headers/library installed
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-git/zlibsearch.patch13
-rw-r--r--meta/packages/qemu/qemu-sdk_git.bb2
-rw-r--r--meta/packages/qemu/qemu_git.bb5
3 files changed, 17 insertions, 3 deletions
diff --git a/meta/packages/qemu/qemu-git/zlibsearch.patch b/meta/packages/qemu/qemu-git/zlibsearch.patch
new file mode 100644
index 000000000..6d7cf0305
--- /dev/null
+++ b/meta/packages/qemu/qemu-git/zlibsearch.patch
@@ -0,0 +1,13 @@
+Index: git/configure
+===================================================================
+--- git.orig/configure 2009-05-24 11:12:34.000000000 +0100
++++ git/configure 2009-05-24 11:12:55.000000000 +0100
+@@ -749,7 +749,7 @@
+ #include <zlib.h>
+ int main(void) { zlibVersion(); return 0; }
+ EOF
+-if $cc $ARCH_CFLAGS -o $TMPE ${OS_CFLAGS} $TMPC -lz > /dev/null 2> /dev/null ; then
++if $cc $CFLAGS $LDFLAGS $ARCH_CFLAGS -o $TMPE ${OS_CFLAGS} $TMPC -lz > /dev/null 2> /dev/null ; then
+ :
+ else
+ echo
diff --git a/meta/packages/qemu/qemu-sdk_git.bb b/meta/packages/qemu/qemu-sdk_git.bb
index 9819d973e..8a04d90da 100644
--- a/meta/packages/qemu/qemu-sdk_git.bb
+++ b/meta/packages/qemu/qemu-sdk_git.bb
@@ -1,6 +1,6 @@
require qemu_git.bb
require qemu-sdk.inc
-PR = "r1"
+PR = "r2"
EXTRA_OECONF +="--target-list=arm-linux-user,arm-softmmu,i386-softmmu --disable-vnc-tls"
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
index fc6d9dc55..b92ecf552 100644
--- a/meta/packages/qemu/qemu_git.bb
+++ b/meta/packages/qemu/qemu_git.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
PV = "0.10.2+git${SRCREV}"
-PR = "r0"
+PR = "r1"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
@@ -18,7 +18,8 @@ SRC_URI = "\
file://workaround_bad_futex_headers.patch;patch=1 \
file://qemu-add-gl-host-code.patch;patch=1 \
file://no-strip.patch;patch=1 \
- file://fix-dirent.patch;patch=1"
+ file://fix-dirent.patch;patch=1 \
+ file://zlibsearch.patch;patch=1 "
# file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1