summaryrefslogtreecommitdiff
path: root/meta/packages/qemu
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-15 12:22:01 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-15 12:33:11 +0100
commitc87bf0cfc656b4ae32b5e6ea926a71135b609a2e (patch)
tree8e561e344145ee4188487c8a53d7582b28dfb018 /meta/packages/qemu
parent5101076eab596d966e5a8a5ef749a48c5334a17e (diff)
downloadopenembedded-core-c87bf0cfc656b4ae32b5e6ea926a71135b609a2e.tar.gz
openembedded-core-c87bf0cfc656b4ae32b5e6ea926a71135b609a2e.tar.bz2
openembedded-core-c87bf0cfc656b4ae32b5e6ea926a71135b609a2e.tar.xz
openembedded-core-c87bf0cfc656b4ae32b5e6ea926a71135b609a2e.zip
qemu: Fix linking of the native package on Fedora 13
Fedora 13 switched the default behaviour of the linker to no longer indirectly link to required libraries (i.e. dependencies of a library already linked to). Therefore we need to explicitly pass the depended on libraries into the linker for building to work on Fedora 13. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-0.12.4/linker-flags.patch22
-rw-r--r--meta/packages/qemu/qemu.inc2
-rw-r--r--meta/packages/qemu/qemu_0.12.4.bb15
-rw-r--r--meta/packages/qemu/qemu_git.bb15
4 files changed, 39 insertions, 15 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/linker-flags.patch b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch
new file mode 100644
index 000000000..7b33aa484
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch
@@ -0,0 +1,22 @@
+Fedora 13 switched the default behaviour of the linker to no longer
+indirectly link to required libraries (i.e. dependencies of a library
+already linked to). Therefore we need to explicitly pass the depended on
+libraries into the linker for building to work on Fedora 13.
+
+More information is available on the Fedora Wiki:
+https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
+
+JL - 15/06/10
+Index: qemu-0.12.4/Makefile.target
+===================================================================
+--- qemu-0.12.4.orig/Makefile.target 2010-06-15 11:21:52.000000000 +0100
++++ qemu-0.12.4/Makefile.target 2010-06-15 11:25:27.212852910 +0100
+@@ -178,7 +178,7 @@
+ obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
+ obj-$(CONFIG_KVM) += kvm.o kvm-all.o
+ obj-$(CONFIG_ISA_MMIO) += isa_mmio.o
+-LIBS+=-lz
++LIBS+=-lz -lX11 -ldl
+
+ sound-obj-y =
+ sound-obj-$(CONFIG_SB16) += sb16.o
diff --git a/meta/packages/qemu/qemu.inc b/meta/packages/qemu/qemu.inc
index 0a0de2cc4..c744990d0 100644
--- a/meta/packages/qemu/qemu.inc
+++ b/meta/packages/qemu/qemu.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qemu.org"
LICENSE = "GPL"
DEPENDS = "zlib"
-EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls --extra-ldflags=-ldl"
+EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls"
#EXTRA_OECONF += "--disable-sdl"
inherit autotools
diff --git a/meta/packages/qemu/qemu_0.12.4.bb b/meta/packages/qemu/qemu_0.12.4.bb
index 43a40c2a2..79b73d38a 100644
--- a/meta/packages/qemu/qemu_0.12.4.bb
+++ b/meta/packages/qemu/qemu_0.12.4.bb
@@ -1,17 +1,18 @@
require qemu.inc
-PR = "r13"
+PR = "r14"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"
SRC_URI = "\
http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \
- file://workaround_bad_futex_headers.patch;patch=1 \
- file://qemu-git-qemugl-host.patch;patch=1 \
- file://no-strip.patch;patch=1 \
- file://fix-dirent.patch;patch=1 \
- file://fix-nogl.patch;patch=1 \
- file://qemugl-allow-glxcontext-release.patch;patch=1"
+ file://workaround_bad_futex_headers.patch \
+ file://qemu-git-qemugl-host.patch \
+ file://no-strip.patch \
+ file://fix-dirent.patch \
+ file://fix-nogl.patch \
+ file://qemugl-allow-glxcontext-release.patch \
+ file://linker-flags.patch"
S = "${WORKDIR}/qemu-${PV}"
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
index 8f39f5b6f..b1468704a 100644
--- a/meta/packages/qemu/qemu_git.bb
+++ b/meta/packages/qemu/qemu_git.bb
@@ -1,19 +1,20 @@
require qemu.inc
PV = "0.12.4"
-PR = "r7"
+PR = "r8"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
FILESDIR = "${WORKDIR}"
SRC_URI = "\
git://git.sv.gnu.org/qemu.git;protocol=git \
- file://workaround_bad_futex_headers.patch;patch=1 \
- file://qemu-git-qemugl-host.patch;patch=1 \
- file://no-strip.patch;patch=1 \
- file://fix-dirent.patch;patch=1 \
- file://fix-nogl.patch;patch=1 \
- file://qemugl-allow-glxcontext-release.patch;patch=1"
+ file://workaround_bad_futex_headers.patch \
+ file://qemu-git-qemugl-host.patch \
+ file://no-strip.patch \
+ file://fix-dirent.patch \
+ file://fix-nogl.patch \
+ file://qemugl-allow-glxcontext-release.patch \
+ file://linker-flags.patch"
S = "${WORKDIR}/git"