summaryrefslogtreecommitdiff
path: root/meta/packages/qmake/qmake2-cross_2.10a.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-12-12 08:43:07 +0000
committerRichard Purdie <richard@openedhand.com>2007-12-12 08:43:07 +0000
commitcfd98f5000b28c9f2958600ba8cebf457ca8f67c (patch)
tree1b2d6c0bd8c0ace62afaba41539d2713b2f9488e /meta/packages/qmake/qmake2-cross_2.10a.bb
parent4db23a9e9061313d0c4c31c7f1b6915e9b1c0d35 (diff)
downloadopenembedded-core-cfd98f5000b28c9f2958600ba8cebf457ca8f67c.tar.gz
openembedded-core-cfd98f5000b28c9f2958600ba8cebf457ca8f67c.tar.bz2
openembedded-core-cfd98f5000b28c9f2958600ba8cebf457ca8f67c.tar.xz
openembedded-core-cfd98f5000b28c9f2958600ba8cebf457ca8f67c.zip
qmake: Turn native package into a cross package since it touches target staging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3333 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qmake/qmake2-cross_2.10a.bb')
-rw-r--r--meta/packages/qmake/qmake2-cross_2.10a.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/qmake/qmake2-cross_2.10a.bb b/meta/packages/qmake/qmake2-cross_2.10a.bb
new file mode 100644
index 000000000..99fe90722
--- /dev/null
+++ b/meta/packages/qmake/qmake2-cross_2.10a.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "TrollTech Makefile Generator"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r1"
+
+QTVER = "qtopia-core-opensource-src-4.3.2"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
+ file://0001-fix-mkspecs.patch;patch=1 \
+ file://use-lflags-last.patch;patch=1 \
+ file://linux-oe-qmake.conf"
+S = "${WORKDIR}/${QTVER}"
+
+# we need the real target system here
+CROSS_SYS := "${TARGET_SYS}"
+inherit autotools cross
+
+export QTDIR = "${S}"
+EXTRA_OEMAKE = "-e"
+
+do_configure() {
+ # Install the OE build templates
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
+ do
+ install -d ${S}/mkspecs/$template
+ install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
+ ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h
+ done
+
+ QMAKESPEC=
+ PLATFORM=${HOST_OS}-oe-g++
+ export PLATFORM
+ # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M:
+ export OE_QMAKE_CC="${CC}"
+ export OE_QMAKE_CFLAGS="${CFLAGS}"
+ export OE_QMAKE_CXX="${CXX}"
+ export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+ export OE_QMAKE_LDFLAGS="${LDFLAGS}"
+ export OE_QMAKE_LINK="${CCLD}"
+ export OE_QMAKE_AR="${AR}"
+ export OE_QMAKE_STRIP="${STRIP}"
+ export OE_QMAKE_UIC="${STAGING_BINDIR_NATIVE}/uic"
+ export OE_QMAKE_MOC="${STAGING_BINDIR_NATIVE}/moc"
+ export OE_QMAKE_RCC="non-existant"
+ export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake"
+ export OE_QMAKE_RPATH="-Wl,-rpath-link,"
+ echo yes | ./configure -prefix ${STAGING_DIR}/${CROSS_SYS}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
+}
+
+do_compile() {
+ :
+}
+
+do_stage() {
+ install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2
+ install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake-qt4
+ install -d ${STAGING_DIR}/${CROSS_SYS}/qt4/
+ cp -PfR mkspecs ${STAGING_DIR}/${CROSS_SYS}/qt4/
+ install -d ${STAGING_DIR}/${HOST_SYS}/qt4/
+ cp -PfR mkspecs ${STAGING_DIR}/${HOST_SYS}/qt4/
+}
+
+do_install() {
+ :
+}