summaryrefslogtreecommitdiff
path: root/meta/packages/tcf-agent/tcf-agent_svn.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-07-23 20:23:33 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-27 22:51:33 -0700
commit90e80aafbd244b00c2ced995feb73af4a739279b (patch)
tree8e64ccb654278fdd7eea981cc9d29a75bd77e58e /meta/packages/tcf-agent/tcf-agent_svn.bb
parentc62be5367cb457ca92e8e803e1ac5d950bc6a278 (diff)
downloadopenembedded-core-90e80aafbd244b00c2ced995feb73af4a739279b.tar.gz
openembedded-core-90e80aafbd244b00c2ced995feb73af4a739279b.tar.bz2
openembedded-core-90e80aafbd244b00c2ced995feb73af4a739279b.tar.xz
openembedded-core-90e80aafbd244b00c2ced995feb73af4a739279b.zip
tcf-agent: add the latest version 0.3.0+svnr1078
install a proper script /etc/init.d/tcf-agent make it autostart in runlevels 3 and 5 Signed-off-by: Qing He <qing.he@intel.com> Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/packages/tcf-agent/tcf-agent_svn.bb')
-rw-r--r--meta/packages/tcf-agent/tcf-agent_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/packages/tcf-agent/tcf-agent_svn.bb b/meta/packages/tcf-agent/tcf-agent_svn.bb
new file mode 100644
index 000000000..b4c70ec8b
--- /dev/null
+++ b/meta/packages/tcf-agent/tcf-agent_svn.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Target Communication Framework"
+HOMEPAGE = "http://dsdp.eclipse.org/dsdp/tm/"
+BUGTRACKER = "https://bugs.eclipse.org/bugs/"
+
+LICENSE = "EPLv1.0 | EDLv1.0"
+LIC_FILES_CHKSUM = "file://../epl-v10.html;md5=7aa4215a330a0a4f6a1cbf8da1a0879f \
+ file://../agent/edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
+
+PV = "0.3.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://dev.eclipse.org/svnroot/dsdp/org.eclipse.tm.tcf/;module=tags/0.3.0/;proto=http \
+ file://terminals_agent.patch \
+ file://fix_tcf-agent.init.patch"
+
+S = "${WORKDIR}/tags/0.3.0/tcf-agent"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "tcf-agent"
+INITSCRIPT_PARAMS = "start 999 3 5 . stop 20 0 1 2 6 ."
+
+# mangling needed for make
+MAKE_ARCH = `echo ${TARGET_ARCH} | sed s,i.86,i686,`
+MAKE_OS = `echo ${TARGET_OS} | sed s,linux,GNU/Linux,`
+
+EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install INSTALLROOT=${D}
+}
+