summaryrefslogtreecommitdiff
path: root/meta/packages/tcltk/tcl/fix_non_native_build_issue.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-08-13 12:24:00 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 23:37:30 +0100
commita2e6b265ed66d5f274507dcfbb3b91c30cc12e3a (patch)
tree2eed7946a157b1e043f3426cdf14ea9f83ab32dd /meta/packages/tcltk/tcl/fix_non_native_build_issue.patch
parentaeb73bdf2035faaa3a9fa889200a831b9217a40f (diff)
downloadopenembedded-core-a2e6b265ed66d5f274507dcfbb3b91c30cc12e3a.tar.gz
openembedded-core-a2e6b265ed66d5f274507dcfbb3b91c30cc12e3a.tar.bz2
openembedded-core-a2e6b265ed66d5f274507dcfbb3b91c30cc12e3a.tar.xz
openembedded-core-a2e6b265ed66d5f274507dcfbb3b91c30cc12e3a.zip
tcl: fix a build issue
This fixes: [BUGID #210] This commit addes a native recipe & a patch for tcl to fix the following build issue | Installing message catalogs | /bin/sh: line 2: ./tclsh: cannot execute binary file | make: *** [install-msgs] Error 126 | FATAL: oe_runmake failed NOTE: package tcl-8.5.8-r0: task do_install: Failed Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/tcltk/tcl/fix_non_native_build_issue.patch')
-rw-r--r--meta/packages/tcltk/tcl/fix_non_native_build_issue.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/packages/tcltk/tcl/fix_non_native_build_issue.patch b/meta/packages/tcltk/tcl/fix_non_native_build_issue.patch
new file mode 100644
index 000000000..b2d98c131
--- /dev/null
+++ b/meta/packages/tcltk/tcl/fix_non_native_build_issue.patch
@@ -0,0 +1,63 @@
+Index: unix/Makefile.in
+===================================================================
+--- unix.orig/Makefile.in
++++ unix/Makefile.in
+@@ -622,20 +622,20 @@ ro-test: tcltest
+ shell: tclsh
+ @LD_LIBRARY_PATH_VAR@="`pwd`:$${@LD_LIBRARY_PATH_VAR@}"; export @LD_LIBRARY_PATH_VAR@; \
+ TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
+- ./tclsh $(SCRIPT)
++ tclsh $(SCRIPT)
+
+ # This target can be used to run tclsh inside either gdb or insight
+ gdb: tclsh
+ @echo "set env @LD_LIBRARY_PATH_VAR@=\"`pwd`:$${@LD_LIBRARY_PATH_VAR@}\"" > gdb.run
+ @echo "set env TCL_LIBRARY=${TCL_BUILDTIME_LIBRARY}" >> gdb.run
+- $(GDB) ./tclsh --command=gdb.run
++ $(GDB) tclsh --command=gdb.run
+ rm gdb.run
+
+ # This target can be used to run tclsh inside ddd
+ ddd: tclsh
+ @echo "set env @LD_LIBRARY_PATH_VAR@=\"`pwd`:$${@LD_LIBRARY_PATH_VAR@}\"" > gdb.run
+ @echo "set env TCL_LIBRARY=${TCL_BUILDTIME_LIBRARY}" >> gdb.run
+- $(DDD) -command=gdb.run ./tclsh
++ $(DDD) -command=gdb.run tclsh
+ rm gdb.run
+
+ VALGRINDARGS=--tool=memcheck --num-callers=8 --leak-resolution=high --leak-check=yes --show-reachable=yes -v
+@@ -648,7 +648,7 @@ valgrind: tclsh tcltest
+ valgrindshell: tclsh
+ @LD_LIBRARY_PATH_VAR@="`pwd`:$${@LD_LIBRARY_PATH_VAR@}"; export @LD_LIBRARY_PATH_VAR@; \
+ TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
+- valgrind $(VALGRINDARGS) ./tclsh $(SCRIPT)
++ valgrind $(VALGRINDARGS) tclsh $(SCRIPT)
+
+ # The following target outputs the name of the top-level source directory for
+ # Tcl (it is used by Tk's configure script, for example). The .NO_PARALLEL
+@@ -817,14 +817,14 @@ install-tzdata: tclsh
+ @echo "Installing time zone data"
+ @@LD_LIBRARY_PATH_VAR@="`pwd`:$${@LD_LIBRARY_PATH_VAR@}"; export @LD_LIBRARY_PATH_VAR@; \
+ TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
+- ./tclsh $(TOOL_DIR)/installData.tcl \
++ tclsh $(TOOL_DIR)/installData.tcl \
+ $(TOP_DIR)/library/tzdata "$(SCRIPT_INSTALL_DIR)"/tzdata
+
+ install-msgs: tclsh
+ @echo "Installing message catalogs"
+ @@LD_LIBRARY_PATH_VAR@="`pwd`:$${@LD_LIBRARY_PATH_VAR@}"; export @LD_LIBRARY_PATH_VAR@; \
+ TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
+- ./tclsh $(TOOL_DIR)/installData.tcl \
++ tclsh $(TOOL_DIR)/installData.tcl \
+ $(TOP_DIR)/library/msgs "$(SCRIPT_INSTALL_DIR)"/msgs
+
+ install-doc: doc
+@@ -1764,7 +1764,7 @@ html-tk: tclsh
+ BUILD_HTML = \
+ @@LD_LIBRARY_PATH_VAR@="`pwd`:$${@LD_LIBRARY_PATH_VAR@}"; export @LD_LIBRARY_PATH_VAR@; \
+ TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
+- ./tclsh $(TOOL_DIR)/tcltk-man2html.tcl --htmldir="$(HTML_INSTALL_DIR)" \
++ tclsh $(TOOL_DIR)/tcltk-man2html.tcl --htmldir="$(HTML_INSTALL_DIR)" \
+ --srcdir=$(TOP_DIR)/.. $(BUILD_HTML_FLAGS)
+
+ #