summaryrefslogtreecommitdiff
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-04-27 16:22:57 +0000
committerRoss Burton <ross@openedhand.com>2007-04-27 16:22:57 +0000
commit11185b17df6964ddf4ccb6e89095e19c175f2462 (patch)
treeb30c698349b88d0d019c596b14bea7050dfc086a /meta/packages/telepathy
parentc1d676e52de9ec31887191c42a843ce6b146cf32 (diff)
downloadopenembedded-core-11185b17df6964ddf4ccb6e89095e19c175f2462.tar.gz
openembedded-core-11185b17df6964ddf4ccb6e89095e19c175f2462.tar.bz2
openembedded-core-11185b17df6964ddf4ccb6e89095e19c175f2462.tar.xz
openembedded-core-11185b17df6964ddf4ccb6e89095e19c175f2462.zip
Add Empathy
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1576 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/empathy-0.1/no-gnome.diff39
-rw-r--r--meta/packages/telepathy/empathy_0.1.bb13
2 files changed, 52 insertions, 0 deletions
diff --git a/meta/packages/telepathy/empathy-0.1/no-gnome.diff b/meta/packages/telepathy/empathy-0.1/no-gnome.diff
new file mode 100644
index 000000000..4dd4a9635
--- /dev/null
+++ b/meta/packages/telepathy/empathy-0.1/no-gnome.diff
@@ -0,0 +1,39 @@
+diff -ur empathy-0.1.orig/configure.ac empathy-0.1/configure.ac
+--- empathy-0.1.orig/configure.ac 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/configure.ac 2007-04-27 17:10:29.000000000 +0100
+@@ -39,12 +39,12 @@
+
+ PKG_CHECK_MODULES(EMPATHY,
+ [
++ libxml-2.0
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+- libgnomeui-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ])
+Only in empathy-0.1: configure.ac~
+diff -ur empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c empathy-0.1/libempathy-gtk/gossip-ui-utils.c
+--- empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/libempathy-gtk/gossip-ui-utils.c 2007-04-27 17:06:48.000000000 +0100
+@@ -31,7 +31,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <libgnome/libgnome.h>
+
+ #include <libmissioncontrol/mc-profile.h>
+
+@@ -1307,7 +1306,7 @@
+ GError *error = NULL;
+
+ real_url = fixup_url (url);
+- gnome_url_show (real_url, &error);
++ g_warning ("TODO: gnome_url_show (real_url, &error);");
+ if (error) {
+ g_warning ("Couldn't show URL:'%s'", real_url);
+ g_error_free (error);
+Only in empathy-0.1/libempathy-gtk: gossip-ui-utils.c~
diff --git a/meta/packages/telepathy/empathy_0.1.bb b/meta/packages/telepathy/empathy_0.1.bb
new file mode 100644
index 000000000..2a6b94a75
--- /dev/null
+++ b/meta/packages/telepathy/empathy_0.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
+
+SRC_URI = "http://projects.collabora.co.uk/~xclaesse/empathy-0.1.tar.gz \
+ file://no-gnome.diff;patch=1"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "/usr/share/mission-control/profiles/*.profile \
+ /usr/share/dbus-1/services/*.service \
+ /usr/share/telepathy/managers/*.chandler"