summaryrefslogtreecommitdiff
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-24 10:39:59 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-24 10:39:59 +0000
commit59a3ba404f64893f35f17e8a0ac182fc49ccbdb3 (patch)
tree4b31ceadd475a6b8f472e957ec1107de9669648a /meta/packages/telepathy
parent76921580538ab7cc9829c1e7ed78420c7e85d6ac (diff)
downloadopenembedded-core-59a3ba404f64893f35f17e8a0ac182fc49ccbdb3.tar.gz
openembedded-core-59a3ba404f64893f35f17e8a0ac182fc49ccbdb3.tar.bz2
openembedded-core-59a3ba404f64893f35f17e8a0ac182fc49ccbdb3.tar.xz
openembedded-core-59a3ba404f64893f35f17e8a0ac182fc49ccbdb3.zip
telepathy: added libtelepathy 0.0.53 and telepathy-gabble 0.5.7 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1538 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/libtelepathy_0.0.53.bb11
-rw-r--r--meta/packages/telepathy/telepathy-gabble-0.5.7/gabble.manager33
-rw-r--r--meta/packages/telepathy/telepathy-gabble_0.5.7.bb17
3 files changed, 61 insertions, 0 deletions
diff --git a/meta/packages/telepathy/libtelepathy_0.0.53.bb b/meta/packages/telepathy/libtelepathy_0.0.53.bb
new file mode 100644
index 000000000..fe409d39b
--- /dev/null
+++ b/meta/packages/telepathy/libtelepathy_0.0.53.bb
@@ -0,0 +1,11 @@
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus"
+LICENSE = "lgpl"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/libtelepathy/libtelepathy-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/meta/packages/telepathy/telepathy-gabble-0.5.7/gabble.manager b/meta/packages/telepathy/telepathy-gabble-0.5.7/gabble.manager
new file mode 100644
index 000000000..9000cd41c
--- /dev/null
+++ b/meta/packages/telepathy/telepathy-gabble-0.5.7/gabble.manager
@@ -0,0 +1,33 @@
+
+[ConnectionManager]
+BusName=org.freedesktop.Telepathy.ConnectionManager.gabble
+ObjectPath=/org/freedesktop/Telepathy/ConnectionManager/gabble
+
+[Protocol jabber]
+param-account=s required register
+param-password=s required register
+param-server=s
+param-resource=s
+param-priority=n
+param-port=q
+param-old-ssl=b
+param-register=b
+param-low-bandwidth=b
+param-https-proxy-server=s
+param-https-proxy-port=q
+param-fallback-conference-server=s
+param-stun-server=s
+param-stun-port=q
+param-ignore-ssl-errors=b
+param-alias=s
+param-mac=s
+param-btid=s
+default-resource=Telepathy
+default-priority=0
+default-port=5222
+default-old-ssl=false
+default-register=false
+default-low-bandwidth=false
+default-https-proxy-port=443
+default-stun-port=3478
+default-ignore-ssl-errors=false
diff --git a/meta/packages/telepathy/telepathy-gabble_0.5.7.bb b/meta/packages/telepathy/telepathy-gabble_0.5.7.bb
new file mode 100644
index 000000000..31ce24751
--- /dev/null
+++ b/meta/packages/telepathy/telepathy-gabble_0.5.7.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Gabble: a Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth"
+LICENSE = "lgpl"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"