summaryrefslogtreecommitdiff
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-29 14:24:48 +0000
committerRoss Burton <ross@openedhand.com>2007-05-29 14:24:48 +0000
commit8ca3683347ebd30b2cf4ba46c85e23692668fe1a (patch)
tree940caa19e3b87cfa6b55f618074024dee0041e72 /meta/packages/telepathy
parent6c11258fb540b1e3f3dba8c9bb0ba18d85d23fe9 (diff)
downloadopenembedded-core-8ca3683347ebd30b2cf4ba46c85e23692668fe1a.tar.gz
openembedded-core-8ca3683347ebd30b2cf4ba46c85e23692668fe1a.tar.bz2
openembedded-core-8ca3683347ebd30b2cf4ba46c85e23692668fe1a.tar.xz
openembedded-core-8ca3683347ebd30b2cf4ba46c85e23692668fe1a.zip
Add gnome-vfs depends, update icon cache
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1807 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/empathy-0.5/no-gnome.diff29
-rw-r--r--meta/packages/telepathy/empathy_0.5.bb9
2 files changed, 25 insertions, 13 deletions
diff --git a/meta/packages/telepathy/empathy-0.5/no-gnome.diff b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
index 3246c8789..29d6276f5 100644
--- a/meta/packages/telepathy/empathy-0.5/no-gnome.diff
+++ b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
@@ -2,23 +2,35 @@ Index: libempathy-gtk/gossip-ui-utils.c
===================================================================
--- libempathy-gtk/gossip-ui-utils.c (revision 99)
+++ libempathy-gtk/gossip-ui-utils.c (working copy)
-@@ -33,7 +33,6 @@
+@@ -33,7 +33,7 @@
#include <glib/gi18n.h>
#include <gtk/gtk.h>
#include <glade/glade.h>
-#include <libgnome/libgnome.h>
++#include <libgnomevfs/gnome-vfs-utils.h>
#include <libmissioncontrol/mc-profile.h>
-@@ -1283,7 +1282,7 @@
- GError *error = NULL;
+@@ -1280,13 +1280,14 @@
+ gossip_url_show (const char *url)
+ {
+ gchar *real_url;
+- GError *error = NULL;
++ GnomeVFSResult res;
real_url = fixup_url (url);
- gnome_url_show (real_url, &error);
-+ g_warning ("TODO: gnome_url_show (real_url, &error);");
- if (error) {
- g_warning ("Couldn't show URL:'%s'", real_url);
- g_error_free (error);
+- if (error) {
+- g_warning ("Couldn't show URL:'%s'", real_url);
+- g_error_free (error);
++ res = gnome_vfs_url_show (real_url);
++ if (res != GNOME_VFS_OK) {
++ g_warning ("Couldn't show URL %s: %s",
++ real_url,
++ gnome_vfs_result_to_string (res));
+ }
+
+ g_free (real_url);
Index: src/empathy-chat-main.c
===================================================================
--- src/empathy-chat-main.c (revision 99)
@@ -117,7 +129,7 @@ Index: configure.ac
===================================================================
--- configure.ac (revision 99)
+++ configure.ac (working copy)
-@@ -62,12 +62,12 @@
+@@ -62,12 +62,13 @@
PKG_CHECK_MODULES(EMPATHY,
[
@@ -128,6 +140,7 @@ Index: configure.ac
gconf-2.0 >= $GCONF_REQUIRED
libglade-2.0 >= $LIBGLADE_REQUIRED
- libgnomeui-2.0
++ gnome-vfs-2.0
libtelepathy >= $TELEPATHY_REQUIRED
libmissioncontrol >= $MISSION_CONTROL_REQUIRED
])
diff --git a/meta/packages/telepathy/empathy_0.5.bb b/meta/packages/telepathy/empathy_0.5.bb
index 99a787318..a9578bea3 100644
--- a/meta/packages/telepathy/empathy_0.5.bb
+++ b/meta/packages/telepathy/empathy_0.5.bb
@@ -1,18 +1,17 @@
DESCRIPTION = "Empathy: a Telepathy based IM client"
HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
LICENSE = "GPL"
-DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade gnome-vfs"
RDEPENDS = "telepathy-mission-control"
RRECOMMENDS = "telepathy-gabble"
-PR="r0"
+PR="r1"
-inherit gnome
+inherit gnome gtk-icon-cache
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.5/empathy-${PV}.tar.bz2 \
file://no-gnome.diff;patch=1;pnum=0"
FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
${datadir}/dbus-1/services/*.service \
- ${datadir}/telepathy/managers/*.chandler \
- ${datadir}/icons"
+ ${datadir}/telepathy/managers/*.chandler"