summaryrefslogtreecommitdiff
path: root/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-01 11:26:28 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-01 11:26:28 +0000
commit1e2d2eb33a5fba729445a71ce855c4536c909de5 (patch)
tree1fdfb3918981274cc622cc32307dbfec1b9d0c5c /meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
parentea605d307c7935119ce75b411beb8890565f73fe (diff)
downloadopenembedded-core-1e2d2eb33a5fba729445a71ce855c4536c909de5.tar.gz
openembedded-core-1e2d2eb33a5fba729445a71ce855c4536c909de5.tar.bz2
openembedded-core-1e2d2eb33a5fba729445a71ce855c4536c909de5.tar.xz
openembedded-core-1e2d2eb33a5fba729445a71ce855c4536c909de5.zip
uboot: added U-Boot for fic-gta01
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1844 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb b/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
new file mode 100644
index 000000000..7c10d653b
--- /dev/null
+++ b/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
@@ -0,0 +1,18 @@
+require uboot-gta01_svn.bb
+
+PROVIDES = ""
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ chmod +x board/neo1973/gta01/split_by_variant.sh
+ oe_runmake gta01bv3_config
+ oe_runmake clean
+ oe_runmake tools
+}
+
+do_deploy () {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_package after do_install