summaryrefslogtreecommitdiff
path: root/meta/packages/ubootchart
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/ubootchart
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.bz2
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.xz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.zip
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/ubootchart')
-rw-r--r--meta/packages/ubootchart/files/sysvinit.patch12
-rw-r--r--meta/packages/ubootchart/files/ubootchart-stop3
-rw-r--r--meta/packages/ubootchart/files/ubootchart.desktop6
-rw-r--r--meta/packages/ubootchart/ubootchart_svn.bb37
4 files changed, 0 insertions, 58 deletions
diff --git a/meta/packages/ubootchart/files/sysvinit.patch b/meta/packages/ubootchart/files/sysvinit.patch
deleted file mode 100644
index de9fb0b17..000000000
--- a/meta/packages/ubootchart/files/sysvinit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: ubootchart.conf
-===================================================================
---- ubootchart.conf (revision 9)
-+++ ubootchart.conf (working copy)
-@@ -1,6 +1,6 @@
-
- # If you want to chain on and run somthing other than /sbin/init...
--export init_prog=/sbin/init
-+export init_prog=/sbin/init.sysvinit
-
- # On startup ubootchart will mount a tmpfs filesystem at this
- # location and chdir here. This is only used for the logging of
diff --git a/meta/packages/ubootchart/files/ubootchart-stop b/meta/packages/ubootchart/files/ubootchart-stop
deleted file mode 100644
index 3444069c9..000000000
--- a/meta/packages/ubootchart/files/ubootchart-stop
+++ /dev/null
@@ -1,3 +0,0 @@
-#! /bin/sh
-
-kill -USR1 $(pidof ubootchartd_bin)
diff --git a/meta/packages/ubootchart/files/ubootchart.desktop b/meta/packages/ubootchart/files/ubootchart.desktop
deleted file mode 100644
index 5552b3bc6..000000000
--- a/meta/packages/ubootchart/files/ubootchart.desktop
+++ /dev/null
@@ -1,6 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/sbin/ubootchart-stop
-Name=Stop Bootchart
-Type=Application
-Categories=Programming;
diff --git a/meta/packages/ubootchart/ubootchart_svn.bb b/meta/packages/ubootchart/ubootchart_svn.bb
deleted file mode 100644
index cd292b694..000000000
--- a/meta/packages/ubootchart/ubootchart_svn.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-DESCRIPTION = "A boot profiling tool"
-HOMEPAGE = "http://code.google.com/p/ubootchart/"
-LICENSE = "GPLv3"
-PV = "0.0+r${SRCREV}"
-PR = "r4"
-
-#RRECOMMENDS = "acct"
-
-SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
- file://sysvinit.patch;patch=1;pnum=0 \
- file://ubootchart-stop \
- file://ubootchart.desktop"
-
-S = "${WORKDIR}/trunk"
-
-inherit update-alternatives
-
-ALTERNATIVE_NAME = "init"
-ALTERNATIVE_LINK = "${base_sbindir}/init"
-ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
-ALTERNATIVE_PRIORITY = "70"
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
-}
-
-do_install() {
- install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
- install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
- install -m 0755 ${S}/ubootchartd ${D}/sbin
- install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
- install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
- install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
-
- install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
- install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
-}